View Issue Details

IDProjectCategoryView StatusLast Update
0000038Xdebug(No Category)public2004-01-05 09:20
ReportersebastianAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0000038: Xdebug segfaults with __destruct()
DescriptionThe attached script runs fine with current PHP 5 HEAD but crashes when Xdebug (current HEAD) is enabled.
Additional InformationReproducing Script:
<?php
class Test {
  private $fp;

  public function __construct() {
    $this->fp = fopen('test', 'w');
  }

  public function __destruct() {
    fputs($this->fp, 'test');
    fclose($this->fp);
  }
}

$test = new Test;
?>


Stacktrace:
add_stack_frame(_zend_execute_data * 0x0012f478, _zend_op_array * 0x00dd12f0, int 2, void * * * 0x00db4248) line 687 + 21 bytes
xdebug_execute(_zend_op_array * 0x00dd12f0, void * * * 0x00db4248) line 843 + 19 bytes
zend_call_function(_zend_fcall_info * 0x0012f584, _zend_fcall_info_cache * 0x0012f550, void * * * 0x00db4248) line 739 + 33 bytes
zend_call_method(_zval_struct * * 0x0012f638, _zend_class_entry * 0x00dd07a8, _zend_function * * 0x00000000, char * 0x105c0684 `string', int 10, _zval_struct * * 0x00000000, int 0, _zval_struct * 0x00000000, _zval_struct * 0x00000000, void * * * 0x00db4248) line 79 + 17 bytes
zend_objects_destroy_object(_zend_object * 0x00dd1530, unsigned int 1, void * * * 0x00db4248) line 79 + 36 bytes
zend_objects_store_del_ref(_zval_struct * 0x00dd28e8, void * * * 0x00db4248) line 142 + 22 bytes
_zval_dtor(_zval_struct * 0x00dd28e8, char * 0x105c3438 `string', unsigned int 355) line 61 + 19 bytes
_zval_ptr_dtor(_zval_struct * * 0x00dd1d64, char * 0x105ce090 `string', unsigned int 196) line 355 + 27 bytes
_zval_ptr_dtor_wrapper(_zval_struct * * 0x00dd1d64) line 196 + 25 bytes
zend_hash_apply_deleter(_hashtable * 0x00e002d0, bucket * 0x00dd1d58) line 568 + 15 bytes
zend_hash_graceful_reverse_destroy(_hashtable * 0x00e002d0) line 634 + 13 bytes
shutdown_executor(void * * * 0x00db4248) line 211 + 26 bytes
zend_deactivate(void * * * 0x00db4248) line 812 + 9 bytes
php_request_shutdown(void * 0x00000000) line 1242 + 9 bytes
main(int 2, char * * 0x00db2c48) line 1028 + 10 bytes
mainCRTStartup() line 338 + 17 bytes
TagsNo tags attached.
Operating System
PHP Version5.0.0-dev

Relationships

duplicate of 0000033 closed Apache crashes with static methods 

Activities

derick

2004-01-05 09:20

administrator   ~0000088

It's a PHP problem which I couldn't fix yet. It's also a duplicate of 0000033.

Issue History

Date Modified Username Field Change
2004-01-04 21:09 sebastian New Issue
2004-01-05 09:20 derick Status new => resolved
2004-01-05 09:20 derick Resolution open => duplicate
2004-01-05 09:20 derick Relationship added duplicate of 0000033
2004-01-05 09:20 derick Assigned To => derick
2004-01-05 09:20 derick Note Added: 0000088
2016-07-31 13:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 13:35 derick Category debugclient (debugging tool) => (No Category)