View Issue Details

IDProjectCategoryView StatusLast Update
0000115Xdebug(No Category)public2006-01-24 22:42
ReporterjuergenAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000115: remote debugging with php 5.0.3
Descriptionin combination with weaverslave remote debugging I have the following problems:
the connection starts (see protocoll)
but the breakpoint was not reached.


protocol:
------begin of protocoll with php 5.0.3 -----------
This is Xdebug version 2.0.0beta3-dev.
Copyright 2002, 2003, 2004 by Derick Rethans,
>option response_format 1
>break D|/xampp/htdocs/phpinfo.php:2
>run
?init D:\xampp\htdocs\phpinfo.php
+OK
?init D:\xampp\htdocs\phpinfo.php
<xdebug><data><code>1</code><message>Breakpoint set on file:line combination.</message></data></xdebug>
+OK
?init D:\xampp\htdocs\phpinfo.php
<xdebug><run><program>D:\xampp\htdocs\phpinfo.php</program></run></xdebug>
+OK
------ end of protocoll with php 5.0.3 ----------------
.... with xdebug 1.3.2 and php 4.3.10 I get these additional
lines ... and so all is ok!
---------begin additional protocoll ------------------
<xdebug><break><breakpoint><function><name>{main}</name><params></params></function><file>D:\xampp\htdocs\phpinfo.php</file><line>0</line></breakpoint><line file='D:\xampp\htdocs\phpinfo.php' no='2'> echo "abc ";</line></break></xdebug>
>bt
>show-local
?cmd
<xdebug><backtrace><stackframe><level>1</level><function><name>{main}</name><params></params></function><file>D:\xampp\htdocs\phpinfo.php</file><line>0</line></stackframe></backtrace></xdebug>
+OK
?cmd
<xdebug><show></show></xdebug>
+OK
?cmd
------------ end additional protocoll -------------------


configuration in php.ini:
------------------------------------------------------
[Zend]
zend_extension_ts="d:\xampp\php\ext\php_xdebug_5_0__2_0dev.dll"
xdebug.remote_enable=on
xdebug.remote_mode=req
xdebug.remote_handler=gdb
xdebug.remote_host=localhost
xdebug.remote_port=17869

;nur Xdebug 2
xdebug.extended_info=1
----------------------------------------------------
Additional Informationxampp: 1.4.11 with php 5.03
PHP API 20031224
PHP Extension 20041030
Zend Extension 220040412




TagsNo tags attached.
Operating Systemtestet with windows 2000 and XP
PHP Version5.0.4

Activities

juergen

2005-02-16 13:51

reporter   ~0000231

I have also contact to Thomas Weinert - the autor of weaverslave.
His point of view ist: the error is not in weaverslave.
Is the "old" GDB-Protocoll furthermore supported in V 2.0 and is there any change in the GDB-protocoll from 1.3.2 to 2.0 ?

derick

2006-01-17 23:25

administrator   ~0000346

Is this still an issue for you?

derick

2006-01-24 22:42

administrator   ~0000363

Can't reproduce this, nor did I receive any feedback whether this still is an issue. Please reopen when you can provide the requested information.

Issue History

Date Modified Username Field Change
2005-02-08 15:03 juergen New Issue
2005-02-16 11:47 derick Severity major => minor
2005-02-16 13:51 juergen Note Added: 0000231
2006-01-17 23:25 derick PHP Version 5.0.3-dev => 5.0.4
2006-01-17 23:25 derick Xdebug Version 2.0-dev => 2.0.0rc1-dev
2006-01-17 23:25 derick Note Added: 0000346
2006-01-17 23:25 derick Status new => feedback
2006-01-24 22:42 derick Status feedback => resolved
2006-01-24 22:42 derick Resolution open => unable to reproduce
2006-01-24 22:42 derick Assigned To => derick
2006-01-24 22:42 derick Note Added: 0000363
2016-07-31 13:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 13:35 derick Category debugclient (debugging tool) => (No Category)