MantisBT - Xdebug
View Issue Details
0000177Xdebug(No Category)public2006-05-01 07:262006-05-27 22:08
judas_iscariote 
derick 
normalmajoralways
resolvedunable to reproduce 
amd64LinuxSUSE 10.0
2.0.0dev 
 
Linux 64 bit
5.1-dev
0000177: debug client does not compile
I neglected to report this before,(long time having the problem), but debugclient does not compiles at all
cd xdebug/debugclient
./buildconf

result:

buildconf: You need GNU Bison 1.28 or newer installed.
make: *** [buildmk.stamp] Error 1

I have bison 1.875 installed... I solved this error using

export LC_ALL=C
(clearly a locale issue)

and then builconf works ok, and ends sucefully.but after that ,configure fails.

config.status: creating Makefile
config.status: error: cannot find input file: Makefile.in




autoconf version 2.59
automake version 1.9.6
libtool version 1.5.18
bison version 1.875
gcc version 4.0.2 2005-09-01

if more information is required, let me to know.
No tags attached.
Issue History
2006-05-01 07:26judas_iscarioteNew Issue
2006-05-01 07:28judas_iscarioteNote Added: 0000388
2006-05-01 12:09derickStatusnew => closed
2006-05-01 12:09derickNote Added: 0000390
2006-05-01 20:36judas_iscarioteStatusclosed => feedback
2006-05-01 20:36judas_iscarioteResolutionopen => reopened
2006-05-01 20:36judas_iscarioteNote Added: 0000391
2006-05-01 20:50derickNote Added: 0000392
2006-05-01 20:50derickAdditional Information Updated
2006-05-01 20:54judas_iscarioteNote Added: 0000393
2006-05-07 23:56derickNote Added: 0000402
2006-05-14 20:13derickNote Added: 0000409
2006-05-27 22:08derickStatusfeedback => resolved
2006-05-27 22:08derickResolutionreopened => unable to reproduce
2006-05-27 22:08derickAssigned To => derick
2006-05-27 22:08derickNote Added: 0000413
2016-07-31 13:35derickCategoryDebug client (console) => debugclient (debugging tool)
2016-07-31 13:35derickCategorydebugclient (debugging tool) => (No Category)

Notes
(0000388)
judas_iscariote   
2006-05-01 07:28   
BTW:: I used the "advanced report" feature of mantis, but I see the relevant info is not visible in non-advanced way :(
(0000390)
derick   
2006-05-01 12:09   
The client doesn't use bison at all, so I just removed the check. It should work now.
(0000391)
judas_iscariote   
2006-05-01 20:36   
no, it doesn't work.

i just checked a fresh copy from the CVS.
run buildocnf

configure: creating ./config.status
config.status: creating Makefile
config.status: error: cannot find input file: Makefile.in

aby other info I can provide to fix the problem ?
(0000392)
derick   
2006-05-01 20:50   
Might have to do with your autoconf/automake versions actually. I use:
Autoconf version 2.13
automake (GNU automake) 1.4-p6

which work fine. PHP and PHP extensions have similar problems with the newer versions I think. Can you check this?
(0000393)
judas_iscariote   
2006-05-01 20:54   
all PHP extensions included in the core, or from PECL ( like APC, filter, gpg,and a very few others I tried) compiles with no problems at all.

PHP6, PHP5_1, and 4_4 compiles with absolutely no issues.


any other hint ?
(0000402)
derick   
2006-05-07 23:56   
The debugclient uses an old script I think. Did you verify if the older tools work with it?
(0000409)
derick   
2006-05-14 20:13   
Did you have a chance to look at the other versions of the auto tools yet?
(0000413)
derick   
2006-05-27 22:08   
Can't reproduce this... nor did I get any more feedback so I'm resolving this issue for now.