MantisBT - Xdebug
View Issue Details
0000003XdebugUsage problems (Wrong Results)public2003-09-03 00:452003-09-03 13:39
rui 
derick 
normalminoralways
closedopen 
 
 
Redhat 8.0
4.3.2
0000003: Debug files (xdebug-xxxxx.txt) don't get updated
1 - Xdebug setup
2 - Added 2 lines to php.ini:
   a) zend_extension="/usr/local/lib/php/extensions/xdebug-4.3.2-1.2.0-lnx.so"
   b) xdebug.auto_profile=1

3 - Stop / Start Apache
4 - Run simple script (Connect to mysql, select 100 records)
5 - File xdebug-xxx.txt is created in /tmp with 0 bytes length
6 - Stop Apache
7 - Debug information is flushed to the file
Only at this point I can see profiling information, after stop apache.
8 - Start apache
9 - Run a few scripts. For each script a xdebug-xxxx.txt file is created, always with zero bytes. Stop Apache again and every file get its content.
Using php 4.3.2 / php 4.3.3. Apache 1.3.28
No tags attached.
Issue History
2003-09-03 00:45ruiNew Issue
2003-09-03 13:39derickNote Added: 0000003
2003-09-03 13:39derickAssigned To => derick
2003-09-03 13:39derickSeverityblock => minor
2003-09-03 13:39derickStatusnew => closed
2003-09-03 13:39derickCategoryDebug client (console) => Usage problems
2016-07-31 13:36derickCategoryUsage problems => Usage problems (Crashes)
2016-07-31 13:38derickCategoryUsage problems (Crashes) => Usage problems (Wrong Results)

Notes
(0000003)
derick   
2003-09-03 13:39   
Xdebug didn't close the files at the end of the request, and thus the file buffer (4kb on Linux) wasn't flushed to disk right after the request, but only when the Apache process ended. I just fixed this in CVS.