View Issue Details

IDProjectCategoryView StatusLast Update
0001549XdebugStacktracespublic2019-02-01 17:09
Reporterdas-peterAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status feedbackResolutionduplicate 
Product Version2.7.0alpha1 
Target Version2.7.0devFixed in Version 
Summary0001549: Segfault when rendering arguments in stack frames for thrown exceptions
DescriptionThe installation of Drupal 8.6 with the config_installer module fails reliably when xdebug 2.6.0 or 2.7.0alpha1 is enabled.
The error doesn't occur if xdebug.default_enable is disabled.
In the "Additional Information" section you'll find the excerpt of the core dumps I was able to create.
Unfortunately that's all information I can provide at this time - I hope it allows to isolate a possible error location.
Steps To ReproduceUnfortunately I wasn't able yet to dumb down the code to trigger the issue.
Additional Informationxdebug 2.6.0

Program terminated with signal SIGSEGV, Segmentation fault.
#0 zval_get_type (pz=0x1f) at /usr/local/include/php/Zend/zend_types.h:390
390 return pz->u1.v.type;
(gdb) bt
#0 zval_get_type (pz=0x1f) at /usr/local/include/php/Zend/zend_types.h:390
#1 xdebug_var_export (struc=<optimized out>, struc@entry=0x7ffcdf777998, str=str@entry=0x55ac727addb0, level=level@entry=1, debug_zval=debug_zval@entry=0, options=options@entry=0x55ac727ef970)
    at /tmp/pear/temp/xdebug/xdebug_var.c:958
0000002 0x00007fa932170a58 in xdebug_get_zval_value (val=<optimized out>, val@entry=0x55ac72558460, debug_zval=debug_zval@entry=0, options=0x55ac727ef970, options@entry=0x0)
    at /tmp/pear/temp/xdebug/xdebug_var.c:1039
0000003 0x00007fa9321688ac in add_single_value (collecton_level=<optimized out>, html=<optimized out>, zv=0x55ac72558460, str=0x7ffcdf777a70) at /tmp/pear/temp/xdebug/xdebug_stack.c:371
0000004 xdebug_append_printable_stack (str=str@entry=0x7ffcdf777a70, html=<optimized out>) at /tmp/pear/temp/xdebug/xdebug_stack.c:451
0000005 0x00007fa932153668 in xdebug_throw_exception_hook (exception=0x7ffcdf777b30) at /tmp/pear/temp/xdebug/xdebug.c:1573
0000006 0x000055ac707e5e60 in zend_throw_exception_internal ()
0000007 0x000055ac709e93d1 in pdo_handle_error ()
------------------------------------------------------------------------
xdebug 2.7.0Alpah1

#0 zval_get_type (pz=0x1f) at /usr/local/include/php/Zend/zend_types.h:390
390 return pz->u1.v.type;
(gdb) bt
#0 zval_get_type (pz=0x1f) at /usr/local/include/php/Zend/zend_types.h:390
#1 xdebug_var_export (struc=<optimized out>, struc@entry=0x7ffc51b698f8, str=str@entry=0x55ad2214c6c0, level=level@entry=1, debug_zval=debug_zval@entry=0, options=options@entry=0x55ad2213ea70)
    at /tmp/pear/temp/xdebug/xdebug_var.c:958
0000002 0x00007fe985570fc8 in xdebug_get_zval_value (val=<optimized out>, val@entry=0x55ad22125720, debug_zval=debug_zval@entry=0, options=0x55ad2213ea70, options@entry=0x0)
    at /tmp/pear/temp/xdebug/xdebug_var.c:1039
0000003 0x00007fe9855693bc in add_single_value (collecton_level=<optimized out>, html=<optimized out>, zv=0x55ad22125720, str=0x7ffc51b699d0) at /tmp/pear/temp/xdebug/xdebug_stack.c:371
0000004 xdebug_append_printable_stack (str=str@entry=0x7ffc51b699d0, html=<optimized out>) at /tmp/pear/temp/xdebug/xdebug_stack.c:451
0000005 0x00007fe985553878 in xdebug_throw_exception_hook (exception=0x7ffc51b69a90) at /tmp/pear/temp/xdebug/xdebug.c:1578
0000006 0x000055ad20039e60 in zend_throw_exception_internal ()
0000007 0x000055ad2023d3d1 in pdo_handle_error ()
TagsNo tags attached.
Operating SystemDebian Stretch / official php docker img
PHP Version7.2.0-7.2.4

Activities

derick

2018-10-20 02:29

administrator   ~0004710

Hi!

From just the back trace I don't think I can find the problem. Would you please try the latest Xdebug beta for PHP 7.3 (2.7.0beta1) and see if the problem persists? If it does, I am going to need a way to reproduce this issue myself locally in some way. Please provide instructions in how to do that (without docker).

cheers,
Derick

derick

2018-12-02 18:56

administrator   ~0004737

Please provide the requested information, so I can try to find and fix the problem, please.

cheers,
Derick

derick

2019-01-23 19:38

administrator   ~0004843

I believe this is a duplicate of 0001583, which ended up being a bug in PHP (to be fixed for PHP 7.3.2). I'm closing this ticket.

derick

2019-01-23 19:39

administrator   ~0004844

Sorry, I closed the wrong issue!

derick

2019-01-29 22:05

administrator   ~0004852

I tried reproducing this issue again, but was unlucky. Can you please provide me with a way on how to reproduce this?

Issue History

Date Modified Username Field Change
2018-05-09 21:26 das-peter New Issue
2018-10-20 02:29 derick Note Added: 0004710
2018-10-20 02:29 derick Assigned To => derick
2018-10-20 02:29 derick Status new => feedback
2018-12-02 18:56 derick Note Added: 0004737
2019-01-23 19:38 derick Note Added: 0004843
2019-01-23 19:38 derick Relationship added duplicate of 0001583
2019-01-23 19:38 derick Status feedback => resolved
2019-01-23 19:38 derick Resolution open => duplicate
2019-01-23 19:39 derick Relationship deleted 0001583
2019-01-23 19:39 derick Note Added: 0004844
2019-01-23 19:39 derick Status resolved => acknowledged
2019-01-23 20:35 derick Status acknowledged => confirmed
2019-01-23 20:35 derick Target Version => 2.7.0rc1
2019-01-23 20:35 derick Summary Segfault during Drupal Installation. => Segfault when rendering arguments in stack frames for thrown exceptions
2019-01-29 22:05 derick Note Added: 0004852
2019-01-29 22:05 derick Status confirmed => feedback
2019-02-01 17:09 derick Target Version 2.7.0rc1 => 2.7.0dev