View Issue Details

IDProjectCategoryView StatusLast Update
0001576XdebugUsage problems (Wrong Results)public2019-01-23 19:37
ReportersmillernlAssigned Toderick 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformOSMac OSOS Version
Product Version2.6.0 
Target VersionFixed in Version 
Summary0001576: mkdir behaviour changes with xdebug enabled
DescriptionWhen using mkdir('somepath', 0775, TRUE) on macOS 10.13.6 with PHP 7.2.10 installed through homebrew the resulting folder permissions are wrong with XDebug enabled.
Steps To ReproduceEnable XDebug.
create a folder using mkdir('somepath/file', 0775, TRUE)
Permissions will be:
d---r-x--- 2 user wheel 64 Sep 14 10:18 somepath

While they should be:
drwxr-xr-x 3 user wheel 96 Sep 14 10:30 somepath
TagsNo tags attached.
Operating SystemmacOS
PHP Version7.2.0-7.2.4

Activities

derick

2018-10-03 18:17

administrator   ~0004702

I can't reproduce this on Linux.

[PHP: 7.2.11-dev] derick@singlemalt:~ $ php -r 'mkdir("/tmp/testing", 0775, TRUE);'

[PHP: 7.2.11-dev] derick@singlemalt:~ $ ls -ld /tmp/testing/
drwxr-xr-x 2 derick derick 4096 Oct 1 19:15 /tmp/testing/

What is your umask set to?

derick

2018-12-02 18:56

administrator   ~0004738

Please provide the requested information, so I can try to find and fix the problem, please.

cheers,
Derick

derick

2019-01-23 19:37

administrator   ~0004842

I can't reproduce this, and the requested feedback was not provided. I'm closing this issue, but feel free to reopen it if you have more information.

Issue History

Date Modified Username Field Change
2018-09-14 09:58 smillernl New Issue
2018-10-03 18:17 derick Note Added: 0004702
2018-10-03 18:17 derick Assigned To => derick
2018-10-03 18:17 derick Status new => feedback
2018-12-02 18:56 derick Note Added: 0004738
2019-01-23 19:37 derick Note Added: 0004842
2019-01-23 19:37 derick Status feedback => resolved
2019-01-23 19:37 derick Resolution open => unable to reproduce