View Issue Details

IDProjectCategoryView StatusLast Update
0001594XdebugCode Coveragepublic2019-08-10 12:22
ReportersantoshAssigned Toderick 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target Version2.8.0devFixed in Version 
Summary0001594: Opening braces covered but closing braces are not covered in code coverage in few scenarios
DescriptionOpening braces covered but closing braces are not covered in code coverage in few scenarios.
End /start of method is showing as covered whereas the logic in the method is not covered as per code coverage.
Few scripts are being executed from Automation test suite but still coming as not executed in code coverage.
Few valid lines are being shown ad dead code/ignored. Ideally it should be covered as part of code coverage .
Excluding of particular file is not supported in code coverage tool as we need to exclude the framework related files.
Variable declaration, Function definition and class statements are ignored by code coverage tool . The tool might need to count them too.
TagsNo tags attached.
Operating System
PHP Version7.2.5-7.2.9

Activities

santosh

2018-12-12 09:21

reporter  

php-version-details.zip (364 bytes)

santosh

2018-12-12 09:36

reporter  

example1.PNG (45,683 bytes)
example1.PNG (45,683 bytes)

santosh

2018-12-12 09:36

reporter  

Example2.PNG (58,130 bytes)
Example2.PNG (58,130 bytes)

derick

2019-01-22 22:24

administrator   ~0004832

I am going to have a look at this after Xdebug 2.7.0 has been released.

derick

2019-07-15 14:52

administrator   ~0005060

I've now just have had a look, but I don't understand what the problem is?

derick

2019-07-26 14:32

administrator   ~0005093

Can you explain what you expected here?

derick

2019-08-05 18:35

administrator   ~0005107

A poke to see whether you can explain your expected output once again.

derick

2019-08-10 12:22

administrator   ~0005114

I fail to see what the problem is here, and no feedback was given when requested. I'm therefore closing this ticket out.

Issue History

Date Modified Username Field Change
2018-12-12 09:21 santosh New Issue
2018-12-12 09:21 santosh File Added: php-version-details.zip
2018-12-12 09:36 santosh File Added: example1.PNG
2018-12-12 09:36 santosh File Added: Example2.PNG
2019-01-22 22:24 derick Note Added: 0004832
2019-01-22 22:24 derick Status new => acknowledged
2019-01-22 22:24 derick Target Version => 2.7.0dev
2019-06-28 11:16 derick Target Version 2.7.0dev => 2.8.0dev
2019-07-15 14:52 derick Assigned To => derick
2019-07-15 14:52 derick Status acknowledged => feedback
2019-07-15 14:52 derick Note Added: 0005060
2019-07-26 14:32 derick Note Added: 0005093
2019-08-05 18:35 derick Note Added: 0005107
2019-08-10 12:22 derick Status feedback => resolved
2019-08-10 12:22 derick Resolution open => unable to reproduce
2019-08-10 12:22 derick Note Added: 0005114