View Issue Details

IDProjectCategoryView StatusLast Update
0001673XdebugRemote Debuggingpublic2019-06-15 16:09
ReporterkrlezaAssigned Toderick 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionduplicate 
PlatformLinuxOSUbuntuOS Version18.04
Product Version2.7.0 
Target VersionFixed in Version 
Summary0001673: 2.7.* version of Xdebug not working in envirment: php-fpm + nginx + docker
DescriptionWhen installing Xdebug in this specific environment: (php-fpm 7.2 + NginX 1.17 + Docker) Xdebug loss track of the conde after the first line and seems to be unable to map code from the docker container.
Steps To ReproduceI made a simple Prove of concept to illustrate, forked from Tarun Lalwani demonstration setup :

git@github.com:Krleza/php-xdebug-docker.git

Build and start container to reproduce the bug. Fails with versions above 2.7 bur works fine with 2.6.1.

Adjust your hot Ip in app.conr file and Xdebug version on Dockerfile
TagsDocker, Nginx, php7.2
Operating SystemUbuntu
PHP Version7.2.10-7.2.14

Relationships

duplicate of 0001637 resolvedderick Breakpoints in PhpStorm stopped working when xdebug switched from v2.7.0beta1 to v2.7.0rc1 

Activities

derick

2019-06-11 14:38

administrator   ~0005036

Are you using this with PhpStorm? If so, which version are you running?

krleza

2019-06-12 06:31

reporter   ~0005037

yes, 2018..1.7

derick

2019-06-15 16:09

administrator   ~0005039

This is a duplicate of 0001637. In order to make this work again, you need to upgrade PhpStorm. See also: https://youtrack.jetbrains.com/issue/WI-43622

Issue History

Date Modified Username Field Change
2019-06-11 12:07 krleza New Issue
2019-06-11 12:07 krleza Tag Attached: Docker
2019-06-11 12:07 krleza Tag Attached: Nginx
2019-06-11 12:07 krleza Tag Attached: php7.2
2019-06-11 14:38 derick Assigned To => derick
2019-06-11 14:38 derick Status new => feedback
2019-06-11 14:38 derick Note Added: 0005036
2019-06-12 06:31 krleza Note Added: 0005037
2019-06-12 06:31 krleza Status feedback => assigned
2019-06-15 16:09 derick Status assigned => resolved
2019-06-15 16:09 derick Resolution open => duplicate
2019-06-15 16:09 derick Note Added: 0005039
2019-06-15 16:09 derick Relationship added duplicate of 0001637