View Issue Details

IDProjectCategoryView StatusLast Update
0000332XdebugUsage problems (Wrong Results)public2009-11-22 17:01
ReporteryettynAssigned Toderick 
PrioritynormalSeverityminorReproducibilityrandom
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000332: xdebug interfear with php parsing in Firefox
DescriptionI am not sure this is a xdebug bug, I am just sure it starts to happen after installing xdebug. What happens is that randomly (it seem), when clicking a link on server where xdebug is installed, instead of parsing the file I get a dialog asking which program to use to open the .php file.

This seem to happens randomly. If I cancel the dialog and click the link again it sometimes parse ok and sometime the dialog comes back one or more times before it parse ok.

I first noticed this on a LAN server where I installed xdebug to debug a site. Same site code also run on a live online server with no such problems. However, emediately after installing xdebug there as well same behaviour started to appear on the live server. This made me conclude it must be related to xdebug.

Nothing is registered in the log file, obviously as the Firefox for some reason doesn't go to the server to parse. This though sounds a bit un-logical to me as if it doesn't go to the server... well maybe it does but doesn'tget the right answer...? I have also tested to access with IE7 and so far have seen no such problems, I really prefere using Firefox though. Also to point, this also happens with the latest Firefox 2.0.0.9 just released.
Additional InformationBoth LAN and online server runs Gentoo-Linux upto date, PHP-5.2.4, Apache 2.2.4, xdebug installed by the gentoo ebuild for version 2.0.1, both client and server installed.

I access both from same workstation running Windows XP SP2, also upto date. I also have Firefox development extention installed. If you need to know anything more please let me know.
TagsNo tags attached.
Operating System
PHP Version5.2.4

Activities

yettyn

2007-11-02 13:40

reporter   ~0000797

Actually, after now using IE7 a bit I notice a "similar" behavior. It doesn't popup a dialog, instead it simply say the page couldn't be accessed and I simply have to refresh one or more times to get to it.

However, sometimes I get strange errors accessing files I know is available. I guess it's xdebug that displays the nice grids with error info ;-) as they have never shown before I installed it. It typically starts with an "...failed to open stream: Resource temporarily unavailable in /var/www/..." error, here's an example, it might not format well but hopefully is readable:


( ! ) Warning: include_once(/var/www/www.astrocalc.com/htdocs/util) [function.include-once]: failed to open stream: Resource temporarily unavailable in /var/www/www.astrocalc.com/htdocs/kernel/kernel_lib.php on line 17
Call Stack
# Time Memory Function Location
1 0.0008 71368 {main}( ) ../index.php:0
2 0.0010 74556 require_once( '/var/www/www.astrocalc.com/htdocs/bit_setup_inc.php' ) ../index.php:12
3 0.0027 155632 require_once( '/var/www/www.astrocalc.com/htdocs/kernel/setup_inc.php' ) ../bit_setup_inc.php:8
4 0.0089 347168 require_once( '/var/www/www.astrocalc.com/htdocs/kernel/kernel_lib.php' ) ../setup_inc.php:16
Dump $_SERVER
Dump $_GET
Dump $_POST
Dump $_COOKIE
Dump $_FILES
Dump $_ENV
Dump $_SESSION
Dump $_REQUEST

( ! ) Warning: include_once() [function.include]: Failed opening '/var/www/www.astrocalc.com/htdocs/util' for inclusion (include_path='.:/usr/share/php5:/usr/share/php') in /var/www/www.astrocalc.com/htdocs/kernel/kernel_lib.php on line 17
Call Stack
# Time Memory Function Location
1 0.0008 71368 {main}( ) ../index.php:0
2 0.0010 74556 require_once( '/var/www/www.astrocalc.com/htdocs/bit_setup_inc.php' ) ../index.php:12
3 0.0027 155632 require_once( '/var/www/www.astrocalc.com/htdocs/kernel/setup_inc.php' ) ../bit_setup_inc.php:8
4 0.0089 347168 require_once( '/var/www/www.astrocalc.com/htdocs/kernel/kernel_lib.php' ) ../setup_inc.php:16

( ! ) Warning: require_once(/var/www/www.astrocalc.com/htdocs/util) [function.require-once]: failed to open stream: Resource temporarily unavailable in /var/www/www.astrocalc.com/htdocs/kernel/BitDbAdodb.php on line 35
Call Stack
# Time Memory Function Location
1 0.0008 71368 {main}( ) ../index.php:0
2 0.0010 74556 require_once( '/var/www/www.astrocalc.com/htdocs/bit_setup_inc.php' ) ../index.php:12
3 0.0027 155632 require_once( '/var/www/www.astrocalc.com/htdocs/kernel/setup_inc.php' ) ../bit_setup_inc.php:8
4 0.0141 487172 require_once( '/var/www/www.astrocalc.com/htdocs/kernel/BitDbAdodb.php' ) ../setup_inc.php:49

( ! ) Fatal error: require_once() [function.require]: Failed opening required '/var/www/www.astrocalc.com/htdocs/util' (include_path='.:/usr/share/php5:/usr/share/php') in /var/www/www.astrocalc.com/htdocs/kernel/BitDbAdodb.php on line 35
Call Stack
# Time Memory Function Location
1 0.0008 71368 {main}( ) ../index.php:0
2 0.0010 74556 require_once( '/var/www/www.astrocalc.com/htdocs/bit_setup_inc.php' ) ../index.php:12
3 0.0027 155632 require_once( '/var/www/www.astrocalc.com/htdocs/kernel/setup_inc.php' ) ../bit_setup_inc.php:8
4 0.0141 487172 require_once( '/var/www/www.astrocalc.com/htdocs/kernel/BitDbAdodb.php' ) ../setup_inc.php:49

yettyn

2007-11-02 13:42

reporter   ~0000798

forgot to say that a refresh of the page makes the error go away and parse the page instead.

derick

2007-11-11 17:39

administrator   ~0000803

Xdebug indeed shows you the nice infos, but the error messages are still coming from PHP itself. As Xdebug runs on the server inside PHP, the browser can definitely not have any influence on this. This is not an Xdebug issue, I think something else is going on for you. Please do upgrade to the latest Xdebug though, which has now been released as 2.0.2.

yettyn

2007-11-23 23:23

reporter   ~0000816

This is really still going on with 2.0.2 and it only happens if xdebug is installed. If I uninstall xdebug, it stops, if I install it starts again. That makes it pretty clear I think, it has something to do with xdebug. I admit it's strange though if I am the only one experience this?

I will try to make it clearer what is happening. It's the same behavior as if you try to run a php file, not having apache properly configurated - the browser tries to "open" the file instead of parse and execute it. I have also tried to set to not open the browser and just use the inline browser, but it still insist on open an instance of Firefox, which is my default browser.

I have since also upgraded to PHP 5.2.5 and apache 2.2.6, with same result. Also note this is remote debugging, and I debug running Eclipse 3.3.1 with PDT and Aptana plugins installed.

yettyn

2007-11-24 11:56

reporter   ~0000817

what kind of feedback do you want?

rion

2008-04-25 17:50

reporter   ~0000844

i have the same problem.
everything above happens for me too
i also have gentoo linux with latest software from portage.
also i've tried to compile xdebug from cvs, but it doesn't help.

please contact me on jabber (rion[@]jabbus.org) if you need more info.

derick

2009-11-22 17:01

administrator   ~0001158

I can not reproduce this.

Issue History

Date Modified Username Field Change
2007-11-02 13:01 yettyn New Issue
2007-11-02 13:40 yettyn Note Added: 0000797
2007-11-02 13:42 yettyn Note Added: 0000798
2007-11-11 17:39 derick Status new => resolved
2007-11-11 17:39 derick Resolution open => no change required
2007-11-11 17:39 derick Assigned To => derick
2007-11-11 17:39 derick Note Added: 0000803
2007-11-23 23:23 yettyn Status resolved => feedback
2007-11-23 23:23 yettyn Resolution no change required => reopened
2007-11-23 23:23 yettyn Note Added: 0000816
2007-11-24 11:56 yettyn Note Added: 0000817
2008-04-25 17:50 rion Note Added: 0000844
2009-11-22 17:01 derick Note Added: 0001158
2009-11-22 17:01 derick Status feedback => resolved
2009-11-22 17:01 derick Resolution reopened => unable to reproduce
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)