View Issue Details

IDProjectCategoryView StatusLast Update
0000849XdebugFeature/Change requestpublic2019-03-31 01:16
ReporterdinuAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionwon't fix 
Product Version 
Target VersionFixed in Version 
Summary0000849: Decrease tracing/profiling overhead
DescriptionAs mentioned, I get 200% to 600% execution timings when tracing a script; is it at all possible to reduce this overhead? Especially since I'm guessing it's roughly linear with the number of function calls, it makes profiling scripts with large number of funcalls difficult.

For instance, I have a script that runs under 400ms, but does in excess of 100K calls; this leads to a traced execution time of 2s. The functions at the bottom of the call tree (those that get called a lot) pull a lot of weight for being traced, although execution in a timed cycle shows they don't pulled nearly as much weight as the profile reports.
TagsNo tags attached.
Operating System
PHP Version5.3.3

Activities

derick

2012-06-25 18:06

administrator   ~0002279

This is definitely on the plan!

derick

2016-12-09 00:37

administrator   ~0003974

Sounds like a magic "make things faster" feature request. I am not a magician :-รพ. In the future, profiling will happen, but this issue is not really actionable, so I'm closing it.

dinu

2019-03-31 01:16

reporter   ~0004980

Since I sometimes like to dabble in magic :)
I leave this here, maybe for V3: https://github.com/exteon/web3tracer
It's a standalone profiler I made that's pretty fast and accurate, and has one feature I find particularly necessary: recursion decoupling in profile.

Issue History

Date Modified Username Field Change
2012-06-02 18:14 dinu New Issue
2012-06-25 18:06 derick Note Added: 0002279
2016-12-09 00:37 derick Note Added: 0003974
2016-12-09 00:37 derick Status new => resolved
2016-12-09 00:37 derick Resolution open => won't fix
2016-12-09 00:37 derick Assigned To => derick
2019-03-31 01:16 dinu Note Added: 0004980