View Issue Details

IDProjectCategoryView StatusLast Update
0000031XdebugUsage problems (Wrong Results)public2003-11-20 15:39
ReporterDaveyAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary0000031: & entity replaced after others, wrong HTML output
DescriptionIt appears that xdebug replaces the & character after replacing all other entities, this means that the & in the entities (for example <) is being replaced and you end up with &lt; being output.
Additional InformationReproduce with:
<?php
    $object = new stdClass();
    $object->foo = 1;
    $object->bar = '<some><xml><tags>&enties</tags></xml></some>';
    $object->baz = 'plain text';
    $object->bat = TRUE;
    $object->qux = 1.8;
    $object->quux = array('quuux');
    var_dump($object);
    echo "<hr />";
    show_source(__FILE__);
?>
TagsNo tags attached.
Operating SystemWinXP Pro w/SP1
PHP Version4.3.3

Activities

derick

2003-11-20 15:39

administrator   ~0000063

Fixed in CVS.

derick

2003-11-20 15:39

administrator   ~0000064

Yeah, let's close it too. :)

Issue History

Date Modified Username Field Change
2003-11-20 14:47 Davey New Issue
2003-11-20 15:39 derick Note Added: 0000063
2003-11-20 15:39 derick Status new => resolved
2003-11-20 15:39 derick Category Debug client (console) => Usage problems
2003-11-20 15:39 derick Status resolved => closed
2003-11-20 15:39 derick Note Added: 0000064
2016-07-31 13:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 13:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)