View Issue Details

IDProjectCategoryView StatusLast Update
0000704Xdebug(No Category)public2011-08-13 15:19
ReporterOndrejBrejlaAssigned Toderick 
PriorityimmediateSeveritycrashReproducibilityalways
Status resolvedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0000704: Every PHP FatalError causes xdebug to crash
DescriptionEverytime something tries to eval a code, which causes PHP FatalError, xdebug crashes. It's so simple.
Steps To ReproduceTry to eval:

nonExistingFunction()
new InstantiateNonExistingObject()

etc.
TagsNo tags attached.
Operating System
PHP Version5.3.5

Relationships

duplicate of 0000606 closedderick evaluate a $this->... expression when $this is not accesible crash xdebug 

Activities

OndrejBrejla

2011-07-21 15:55

reporter   ~0001763

It's connected with issues: 688, 678, 689, 606.

Just everytime the evaled code throws FatalError.

derick

2011-08-13 15:19

administrator   ~0001779

Fixed for 2.1.3 and 2.2dev.

Issue History

Date Modified Username Field Change
2011-07-21 15:52 OndrejBrejla New Issue
2011-07-21 15:55 OndrejBrejla Note Added: 0001763
2011-08-01 20:56 derick Relationship added duplicate of 0000606
2011-08-01 20:56 derick Status new => resolved
2011-08-01 20:56 derick Resolution open => duplicate
2011-08-01 20:56 derick Assigned To => derick
2011-08-13 15:19 derick Note Added: 0001779
2016-07-31 12:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 12:35 derick Category debugclient (debugging tool) => (No Category)