MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000864Xdebug(No Category)public2012-06-29 17:282015-06-14 19:33
Reporternaitsirch 
Assigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionduplicate 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version2.3.3 
Summary0000864: No Attributes are shown if an Object extends ArrayIterator
DescriptionHi,
when I instantiate a class which extends PHP's ArrayIterator and add some further attributes to the class, the object is just shown as an empty object by xdebug.

Best regards.
TagsNo tags attached.
Operating SystemWin 7
PHP Version5.3.13
Attached Files

- Relationships
duplicate of 0000686closedderick Not possible to inspect SplObjectStorage instances with Xdebug 

-  Notes
(0002316)
naitsirch (reporter)
2012-07-02 07:53

Here a small script to reproduce:

<?php
class A extends ArrayIterator
{
    protected $aa;
    public function __construct()
    {
        $this->aa = 302;
        parent::__construct(array());
    }
}

$a = new A();
print_r($a); // put breakpoint here
?>

The script's output is:
A Object
(
    [aa:protected] => 302
    [storage:ArrayIterator:private] => Array
        (
        )

)

I have tested it in Xdebug Version 2.1.4 and 2.2.0
(0002704)
derick (administrator)
2014-02-27 19:38

CLosing as a duplicate of 0000686.
(0003118)
derick (administrator)
2015-06-14 19:33

This wasn't actually a duplicate. Closing it now though, as it's fixed for Xdebug 2.2.3 and 3.0dev. Thanks for the report!

- Issue History
Date Modified Username Field Change
2012-06-29 17:28 naitsirch New Issue
2012-07-02 07:53 naitsirch Note Added: 0002316
2014-02-27 19:38 derick Note Added: 0002704
2014-02-27 19:38 derick Relationship added duplicate of 0000686
2014-02-27 19:38 derick Status new => resolved
2014-02-27 19:38 derick Resolution open => duplicate
2014-02-27 19:38 derick Assigned To => derick
2015-06-14 19:33 derick Note Added: 0003118
2015-06-14 19:33 derick Status resolved => closed
2015-06-14 19:33 derick Fixed in Version => 2.3.3
2016-07-31 13:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 13:35 derick Category debugclient (debugging tool) => (No Category)


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker