MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001241XdebugUsage problems (Wrong Results)public2015-12-30 15:462016-06-06 22:28
Reporterderick 
Assigned Toderick 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version2.4.0rc3 
Target Version2.4.0Fixed in Version2.4.1 
Summary0001241: Xdebug doesn't handle FAST_RET and FAST_CALL opcodes for branch/dead code analysis, and path coverage
DescriptionWhen analysing:

<code>
<?php
function extractFile()
{
    try {
        echo "try\n";
    } catch (Catch1 $e) {
        echo "catch1\n";
    } catch (Catch2 $e) {
        echo "catch2\n";
    } finally {
        echo "finally\n";
    }
    echo "end\n";
}

extractFile();
?>
</code>

It fails to see any jumps in FAST_RET and FAST_CALL.
TagsNo tags attached.
Operating System
PHP Version7.1-dev
Attached Files

- Relationships

-  Notes
(0003424)
derick (administrator)
2016-01-19 22:29

Pull request at https://github.com/xdebug/xdebug/pull/256, [^] but breaks due to PHP 7.0.[0-2] having a bug in line numbers for FAST_CALL.

- Issue History
Date Modified Username Field Change
2015-12-30 15:46 derick New Issue
2016-01-19 22:29 derick Note Added: 0003424
2016-01-19 22:29 derick Status new => resolved
2016-01-19 22:29 derick Resolution open => suspended
2016-01-19 22:29 derick Assigned To => derick
2016-01-19 22:29 derick PHP Version 5.6.15-5.6.19 => 7.1-dev
2016-01-19 22:29 derick Status resolved => assigned
2016-01-25 21:56 derick Status assigned => closed
2016-01-25 21:56 derick Fixed in Version => 2.4.0
2016-01-25 21:59 derick Fixed in Version 2.4.0 => 2.4.0rc4
2016-06-06 22:24 derick Fixed in Version 2.4.0rc4 => 2.4.1
2016-06-06 22:28 derick Resolution suspended => fixed
2016-07-31 13:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 13:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker