View Issue Details

IDProjectCategoryView StatusLast Update
0001404XdebugUsage problems (Wrong Results)public2017-04-17 17:50
ReporteronkeltemAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSDebianOS VersionJessy
Product Version2.5.0 
Target VersionFixed in Version2.5.2 
Summary0001404: Execution time is calculated incorretly
DescriptionThere's a problem with profiler logs created while executing Drupal `drush` script: execution time counts to very bug number.

There are actually two log files created upon each drush run because of the way it works — small and big, so I attach both.

Let me note that on IRC Derick assumed it can be related to register_shutdown_function() usage.
Steps To ReproduceI haven't created a clean test-case for this. But I believe anyone can reproduce it with these simple steps:

1) composer require drush/drush:8.1.10
2) ./vendor/bin/drush

Now see in the resulting profiler log file.
TagsNo tags attached.
Operating System
PHP Version5.6.20-5.6.24

Activities

onkeltem

2017-03-08 11:28

reporter  

drush_launch.tar.bz2 (213,431 bytes)

derick

2017-04-17 17:50

administrator   ~0004272

This ended up being two bugs. Both this one, as well as 0001419. Both are fixed for the upcoming 2.5.2 release though.

Thanks for your report.

Issue History

Date Modified Username Field Change
2017-03-08 11:28 onkeltem New Issue
2017-03-08 11:28 onkeltem File Added: drush_launch.tar.bz2
2017-04-17 17:50 derick Note Added: 0004272
2017-04-17 17:50 derick Status new => closed
2017-04-17 17:50 derick Assigned To => derick
2017-04-17 17:50 derick Resolution open => fixed
2017-04-17 17:50 derick Fixed in Version => 2.5.2