View Issue Details

IDProjectCategoryView StatusLast Update
0001421XdebugUsage problems (Wrong Results)public2017-04-18 12:57
Reportermassimiliano.manciniAssigned Toderick 
PriorityimmediateSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Platform32 bitOSWindowsOS Version10
Product Version2.5.2 
Target Version2.5.3Fixed in Version2.5.3 
Summary0001421: Xdebug crashes when it is loaded without pcntl being present
Descriptionxdebug dll crashes php cli
Steps To ReproduceUse internal php server, open browser and call any php file. Suddenly cli crashes
Additional InformationLoadedModule[0]=c:\program files\php\php.exe
LoadedModule[1]=C:\WINDOWS\SYSTEM32\ntdll.dll
LoadedModule[2]=C:\WINDOWS\System32\KERNEL32.DLL
LoadedModule[3]=C:\WINDOWS\System32\KERNELBASE.dll
LoadedModule[4]=C:\WINDOWS\System32\WS2_32.dll
LoadedModule[5]=c:\program files\php\php7.dll
LoadedModule[6]=C:\WINDOWS\System32\sechost.dll
LoadedModule[7]=C:\WINDOWS\System32\RPCRT4.dll
LoadedModule[8]=C:\WINDOWS\System32\SHELL32.dll
LoadedModule[9]=C:\WINDOWS\System32\msvcrt.dll
LoadedModule[10]=C:\WINDOWS\System32\cfgmgr32.dll
LoadedModule[11]=C:\WINDOWS\System32\windows.storage.dll
LoadedModule[12]=C:\WINDOWS\System32\combase.dll
LoadedModule[13]=C:\WINDOWS\System32\ucrtbase.dll
LoadedModule[14]=C:\WINDOWS\System32\bcryptPrimitives.dll
LoadedModule[15]=C:\WINDOWS\System32\powrprof.dll
LoadedModule[16]=C:\WINDOWS\System32\advapi32.dll
LoadedModule[17]=C:\WINDOWS\System32\shlwapi.dll
LoadedModule[18]=C:\WINDOWS\System32\GDI32.dll
LoadedModule[19]=C:\WINDOWS\System32\gdi32full.dll
LoadedModule[20]=C:\WINDOWS\System32\USER32.dll
LoadedModule[21]=C:\WINDOWS\System32\win32u.dll
LoadedModule[22]=C:\WINDOWS\System32\kernel.appcore.dll
LoadedModule[23]=C:\WINDOWS\System32\shcore.dll
LoadedModule[24]=C:\WINDOWS\System32\profapi.dll
LoadedModule[25]=C:\WINDOWS\System32\ole32.dll
LoadedModule[26]=C:\WINDOWS\SYSTEM32\VCRUNTIME140.dll
LoadedModule[27]=C:\WINDOWS\System32\PSAPI.DLL
LoadedModule[28]=C:\WINDOWS\SYSTEM32\DNSAPI.dll
LoadedModule[29]=C:\WINDOWS\System32\NSI.dll
LoadedModule[30]=C:\WINDOWS\System32\IMM32.DLL
LoadedModule[31]=C:\WINDOWS\SYSTEM32\IPHLPAPI.DLL
LoadedModule[32]=c:\program files\ansicon\ANSI32.dll
LoadedModule[33]=C:\Program Files\php\ext\php_xdebug-2.5.2-7.1-vc14-nts.dll
LoadedModule[34]=c:\program files\php\ext\php_curl.dll
LoadedModule[35]=C:\WINDOWS\System32\WLDAP32.dll
LoadedModule[36]=c:\program files\php\libssh2.dll
LoadedModule[37]=C:\WINDOWS\System32\Normaliz.dll
LoadedModule[38]=c:\program files\php\nghttp2.dll
LoadedModule[39]=c:\program files\php\LIBEAY32.dll
LoadedModule[40]=c:\program files\php\SSLEAY32.dll
LoadedModule[41]=C:\WINDOWS\System32\CRYPT32.dll
LoadedModule[42]=C:\WINDOWS\System32\MSASN1.dll
LoadedModule[43]=c:\program files\php\ext\php_intl.dll
LoadedModule[44]=c:\program files\php\icuin57.dll
LoadedModule[45]=c:\program files\php\icuuc57.dll
LoadedModule[46]=c:\program files\php\icuio57.dll
LoadedModule[47]=C:\WINDOWS\SYSTEM32\MSVCP140.dll
LoadedModule[48]=c:\program files\php\icudt57.dll
LoadedModule[49]=c:\program files\php\ext\php_imap.dll
LoadedModule[50]=C:\WINDOWS\SYSTEM32\WINMM.dll
LoadedModule[51]=C:\WINDOWS\SYSTEM32\Secur32.dll
LoadedModule[52]=C:\WINDOWS\SYSTEM32\WINMMBASE.dll
LoadedModule[53]=C:\WINDOWS\SYSTEM32\SSPICLI.DLL
LoadedModule[54]=c:\program files\php\ext\php_mbstring.dll
LoadedModule[55]=c:\program files\php\ext\php_openssl.dll
LoadedModule[56]=c:\program files\php\ext\php_pdo_sqlite.dll
LoadedModule[57]=C:\WINDOWS\system32\mswsock.dll
LoadedModule[58]=C:\Windows\System32\rasadhlp.dll
LoadedModule[59]=C:\WINDOWS\System32\fwpuclnt.dll
LoadedModule[60]=C:\WINDOWS\SYSTEM32\bcrypt.dll
TagsNo tags attached.
Operating Systemwindows 10 32bit
PHP Version7.1.0-7.1.4

Relationships

has duplicate 0001422 resolvedderick Can not load extension, getting segfault 

Activities

derick

2017-04-18 10:24

administrator   ~0004275

How exactly does it crash?
Does it need a script?
Does it crash with just with "php -v" on the command line?
And do you get a more reasonable error message?

It would also be helpful to follow the instructions at https://bugs.php.net/bugs-generating-backtrace-win32.php

derick

2017-04-18 10:41

administrator   ~0004276

No need to try this, I see what the problem is.

derick

2017-04-18 12:57

administrator   ~0004279

Fixed for Xdebug 2.5.3, which I will release later today.

Issue History

Date Modified Username Field Change
2017-04-18 07:40 massimiliano.mancini New Issue
2017-04-18 10:24 derick Note Added: 0004275
2017-04-18 10:24 derick Assigned To => derick
2017-04-18 10:24 derick Status new => feedback
2017-04-18 10:41 derick Note Added: 0004276
2017-04-18 10:41 derick Status feedback => confirmed
2017-04-18 10:41 derick Target Version => 2.5.3
2017-04-18 10:41 derick Summary xdebug dll crashes php cli => Xdebug crashes when it is loaded without pcntl being present
2017-04-18 12:57 derick Note Added: 0004279
2017-04-18 12:57 derick Status confirmed => closed
2017-04-18 12:57 derick Resolution open => fixed
2017-04-18 12:57 derick Fixed in Version => 2.5.3
2017-04-18 14:19 derick Relationship added has duplicate 0001422