View Issue Details

IDProjectCategoryView StatusLast Update
0001639XdebugInstallationpublic2019-02-23 15:19
ReporterderickAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformgcc-8 or clangOSOS Version
Product Version2.7.0RC2 
Target Version2.7.0Fixed in Version2.7.0 
Summary0001639: Compile warning/error on GCC 8 or Clang due to "break intentionally missing"
DescriptionCompile Xdebug with the "./rebuild.sh" script with GCC 8 installed.

Result:

cc -g -O0 -Wall -Wdeclaration-after-statement -Wdiscarded-qualifiers -Wempty-body -Wenum-compare -Werror -Wextra -Wimplicit-fallthrough -Winit-self -Wlogical-not-parentheses -Wlogical-op -Wmaybe-uninitialized -Wmissing-format-attribute -Wno-missing-field-initializers -Wno-sign-compare -Wno-unused-but-set-variable -Wno-unused-parameter -Wno-variadic-macros -Wparentheses -Wsizeof-array-argument -Wwrite-strings -fdiagnostics-show-option -fno-exceptions -fno-omit-frame-pointer -fno-optimize-sibling-calls -fstack-protector -I. -I/home/derick/dev/php/xdebug-xdebug -DPHP_ATOM_INC -I/home/derick/dev/php/xdebug-xdebug/include -I/home/derick/dev/php/xdebug-xdebug/main -I/home/derick/dev/php/xdebug-xdebug -I/usr/local/php/7.3dev/include/php -I/usr/local/php/7.3dev/include/php/main -I/usr/local/php/7.3dev/include/php/TSRM -I/usr/local/php/7.3dev/include/php/Zend -I/usr/local/php/7.3dev/include/php/ext -I/usr/local/php/7.3dev/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O0 -c /home/derick/dev/php/xdebug-xdebug/xdebug_handler_dbgp.c  -fPIC -DPIC -o .libs/xdebug_handler_dbgp.o
/home/derick/dev/php/xdebug-xdebug/xdebug_compat.c: In function ‘xdebug_addslashes’:
/home/derick/dev/php/xdebug-xdebug/xdebug_compat.c:276:15: error: this statement may fall through [-Werror=implicit-fallthrough=]
     *target++ = '\\';
     ~~~~~~~~~~^~~~~~
/home/derick/dev/php/xdebug-xdebug/xdebug_compat.c:278:4: note: here
    default:
    ^~~~~~~
cc1: all warnings being treated as errors
make: *** [Makefile:234: xdebug_compat.lo] Error 1
make: *** Waiting for unfinished jobs....
TagsNo tags attached.
Operating System
PHP Version7.3.0-7.3.1

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2019-02-23 15:07 derick New Issue
2019-02-23 15:07 derick Status new => assigned
2019-02-23 15:07 derick Assigned To => derick
2019-02-23 15:10 derick Summary Compile warning/error on GCC 8 or Clang due to implicit fallback => Compile warning/error on GCC 8 or Clang due to "break intentionally missing"
2019-02-23 15:19 derick Status assigned => closed
2019-02-23 15:19 derick Resolution open => fixed
2019-02-23 15:19 derick Fixed in Version => 2.7.0