View Issue Details

IDProjectCategoryView StatusLast Update
0001733XdebugCode Coveragepublic2020-01-10 09:34
ReporterderickAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version2.9.1Fixed in Version2.9.1 
Summary0001733: SEND_VAR_NO_REF_EX opcode, used for require(), is not overloaded
DescriptionFrom https://github.com/sebastianbergmann/php-code-coverage/issues/719
Steps To Reproduce<code>
<?php
declare(strict_types=1);
namespace FancyNamespace;

class ConfigProvider
{
    public function __invoke(): array
    {
        return array_merge(
            require(__DIR__ . '/foo.php'),
            require(__DIR__ . '/bar.php'),
        );
    }
}
</code>

the first require is never covered
TagsNo tags attached.
Operating System
PHP Version7.4.0-7.4.4

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2020-01-10 08:32 derick New Issue
2020-01-10 08:32 derick Status new => assigned
2020-01-10 08:32 derick Assigned To => derick
2020-01-10 09:34 derick Status assigned => closed
2020-01-10 09:34 derick Resolution open => fixed
2020-01-10 09:34 derick Fixed in Version => 2.9.1