View Issue Details

IDProjectCategoryView StatusLast Update
0001782XdebugStep Debuggingpublic2020-05-28 13:06
ReporterjehawAssigned Toderick 
PriorityhighSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version2.9.1 
Target VersionFixed in Version2.9.6 
Summary0001782: Cookie "XDEBUG_SESSION" will be soon rejected because it has the “sameSite” attribute set to none
DescriptionIn Mozilla FireFox v.76.0b8 Developer (64-bit) after the last update the following message started to appear in the Console during debugging:

Cookie “XDEBUG_SESSION” will be soon rejected because it has the “sameSite” attribute set to “none” or an invalid value, without the “secure” attribute. To know more about the “sameSite“ attribute, read https://developer.mozilla.org/docs/Web/HTTP/Cookies

If this occurs, not sure if the debug will work when pages are changed. Thought you need to be aware as this may or may not have serious impact on debugging sessions.
Steps To ReproduceStart a debugging session for a web page in PHP using Mozilla FireFox (v.76.0 or later).
After page loads, press F12 to open Developer Console and click the Console tab.
Message appears.
Additional InformationI am using Visual Studio 2019 v.16.5.3, PHP Tools for Visual Studio v.1.32.11768.2019, and Mozilla FireFox v.76.0b8 Developer
TagsNo tags attached.
Operating System
PHP Version7.3.5-7.3.9

Activities

derick

2020-05-07 16:00

administrator   ~0005411

Hi,

I can only fix this for PHP 7.3 and higher, because earlier versions of PHP do not have the API to set SameSite cookies. I've also noticed that this problem exists in the helper extensions for Firefox and Chrome. I've submitted two pull requests for them:

- https://github.com/mac-cain13/xdebug-helper-for-chrome/pull/106
- https://github.com/BrianGilbert/xdebug-helper-for-firefox/pull/19

I'll have a fix for Xdebug 2.9/3.0 in a bit, after I figure out how to test this :-)

cheers,
Derick

Issue History

Date Modified Username Field Change
2020-05-07 15:13 jehaw New Issue
2020-05-07 16:00 derick Assigned To => derick
2020-05-07 16:00 derick Status new => assigned
2020-05-07 16:00 derick Note Added: 0005411
2020-05-07 17:53 derick Status assigned => closed
2020-05-07 17:53 derick Resolution open => fixed
2020-05-07 17:53 derick Fixed in Version => 2.9.6
2020-05-28 13:06 derick Severity major => feature
2020-05-28 13:06 derick Category Feature/Change request => Step Debugging