View Issue Details

IDProjectCategoryView StatusLast Update
0002025XdebugStep Debuggingpublic2021-10-04 09:29
Reporterderick Assigned Toderick  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version3.1.0beta2 
Target Version3.1devFixed in Version3.1.0 
Summary0002025: Anonymous classes which extend are not detected as anonymous classes since PHP 8.0
DescriptionXdebug has code to detect that a class name is that of an anonymous class. In PHP 7.4 and earlier, a check against /^class@anonymous/ worked, including for anonymous classes extending another class. Since PHP 8.0, this internal marker than changed to {parent-class}@anonymous, thwarting my check.
TagsNo tags attached.
Operating System
PHP Version8.0.5-8.0.9

Activities

Issue History

Date Modified Username Field Change
2021-10-01 12:26 derick New Issue
2021-10-01 16:21 derick Note Added: 0006070
2021-10-01 16:52 derick Assigned To => derick
2021-10-01 16:52 derick Status new => closed
2021-10-01 16:52 derick Resolution open => fixed
2021-10-01 16:52 derick Fixed in Version => 3.1dev
2021-10-04 09:29 derick Fixed in Version 3.1dev => 3.1.0