View Issue Details

IDProjectCategoryView StatusLast Update
0002125XdebugCode Coveragepublic2022-10-10 15:51
Reporterderick Assigned Toderick  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.2.0alpha3 
Target Version3.2devFixed in Version3.2.0RC1 
Summary0002125: Crash with PHP 8.2 on 32-bit due to change in "not set" value with CATCH opcode
Description

With PHP 8.2, there are changes how the engine stores which "CATCH" opcode is the last one, and Xdebug still tests only for the old condition. This results in crashes.

TagsNo tags attached.
Operating System
PHP Version8.2-dev

Activities

Issue History

Date Modified Username Field Change
2022-10-05 13:22 derick New Issue
2022-10-05 13:27 derick Summary PHP 8.2 changes "not set" elements for CATCH opcode, resulting in crash => Crash with PHP 8.2 on 32-bit due to change in "not set" value with CATCH opcode
2022-10-05 13:27 derick Note Added: 0006387
2022-10-05 13:32 derick Assigned To => derick
2022-10-05 13:32 derick Status new => closed
2022-10-05 13:32 derick Resolution open => fixed
2022-10-05 13:32 derick Fixed in Version => 3.2dev
2022-10-10 15:51 derick Fixed in Version 3.2dev => 3.2.0RC1