View Issue Details

IDProjectCategoryView StatusLast Update
0000218XdebugUsage problems (Wrong Results)public2007-02-28 20:43
ReporterhemnaAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000218: show_exception_trace="0" ignored
Descriptionmy php.ini has
xdebug.show_exception_trace="0"
set, but xdebug seems to ignore the 'off' setting.


Additional InformationI have
display_errors = On
log_errors = On.

xdebug is dumping every exception that happens to my error log file. I really like this feature, but xdebug doesn't seem to honor the off setting.
TagsNo tags attached.
Operating Systemgentoo linux
PHP Version5.1.6

Activities

derick

2006-11-16 14:31

administrator   ~0000488

I can not reproduce this with the lastest cvs version:

derick@kossu:~$ php -dxdebug.show_exception_trace=1 -r 'function a() { try { throw new Exception( "test"); } catch ( Exception $e ) { echo "caught\n"; } } function b() { a(); } b();'

Exception: test in Command line code on line 1

Call Stack:
    0.0005 262144 1. {main}() Command line code:0
    0.0005 262144 2. b() Command line code:1
    0.0005 262144 3. a() Command line code:1

caught

derick@kossu:~$ php -dxdebug.show_exception_trace=0 -r 'function a() { try { throw new Exception( "test"); } catch ( Exception $e ) { echo "caught\n"; } } function b() { a(); } b();'
caught


Could you please try the latest cvs version?

derick

2006-11-21 19:48

administrator   ~0000490

Reminder sent to hemna

Could you please provide the wanted information?

derick

2006-12-12 13:03

administrator   ~0000513

Unable to duplicate, and no feedback given.

derick

2007-02-28 20:43

administrator   ~0000576

Fixed in CVS now, thanks for your report. (Duplicate of 0000243).

Issue History

Date Modified Username Field Change
2006-11-14 02:08 hemna New Issue
2006-11-16 14:31 derick Note Added: 0000488
2006-11-16 14:31 derick Status new => feedback
2006-11-21 19:48 derick Note Added: 0000490
2006-12-12 13:03 derick Status feedback => resolved
2006-12-12 13:03 derick Resolution open => unable to reproduce
2006-12-12 13:03 derick Assigned To => derick
2006-12-12 13:03 derick Note Added: 0000513
2007-02-28 20:43 derick Status resolved => closed
2007-02-28 20:43 derick Note Added: 0000576
2016-07-31 13:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 13:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)