View Issue Details

IDProjectCategoryView StatusLast Update
0000230XdebugUsage problems (Wrong Results)public2007-02-28 20:43
ReportersheepyAssigned To 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary0000230: remote debug crash at 000116d1 on runtime err/warning
DescriptionWith remote debug on, when a runtime error/warning is generated, Apache crash at downloaded xdebug dll offset 000116d1
Apache restarts automatically

It happens with call to non-existant method, referencing non-existant var, or even trigger_error
Compile-time error shows up without problem
Additional InformationWeaverslave's protocol window capture normal message but xdebug gen no remote log (maybe I set it wrong?)

---- Captured communitaction ---
This is Xdebug version 2.0.0RC2-dev.
Copyright 2002, 2003, 2004 by Derick Rethans,
>option response_format 1
>run
?init E:\wamp\www\squarefoot\test.php
+OK
?init E:\wamp\www\squarefoot\test.php
<xdebug><run><program>E:\wamp\www\squarefoot\test.php</program></run></xdebug>
+OK
---- End of captured communitaction ---

PHP error log seems to be normal in simple test case, although I don't see any error logged for my original system where I first encountered the crash.

Apache's log says:

[Mon Dec 18 15:43:07 2006] [notice] Parent: child process exited with status 3221225477 -- Restarting.
TagsNo tags attached.
Operating SystemWindows XP Pro / Apache 2.2.3
PHP Version4.4.4

Activities

derick

2006-12-19 19:14

administrator   ~0000523

I can not reproduce this with the latest CVS version on Linux. Could you please provide a short (but complete) reproducing script?

sheepy

2006-12-20 04:50

reporter   ~0000524

<?php
function test() {}
test(); // Breakpoint here works

$x; // Crash here

?>

When Weaverslave's debugger is off I got a normal error stack trace from xdebug. When it is on I got crash and apache restarts.

What's curious is, I got this case while I was trying to produce a minimal test case for another crash that seems to be the same, except that I didn't get any error or notice when I run that without debugger.
It's possible that the error is silenced, I've yet to trace to that point - the debugger won't crash until the error is thrown. It's the same at home where I use XP Pro with Apache 2.0.52 and IIRC PHP 4.4.4.

I am using pre-compiled windows module, since I have no C compiler at work.

Here's my xdebug ini, in case it helps:

[xdebug]
zend_extension_ts="E:\wamp\php4\extensions\php_xdebug.dll"
xdebug.manual_url="http://www.php.net"
xdebug.auto_trace=0
xdebug.profiler_enable = 0
xdebug.profiler_append = 0
xdebug.profiler_output_dir="E:\wamp\logs\profile"
xdebug.remote_autostart=1
xdebug.remote_enable=on
xdebug.remote_mode=req
xdebug.remote_handler=gdb
xdebug.remote_host=localhost
xdebug.remote_port=17869
xdebug.extended_info=1
xdebug.remote_log = "E:\wamp\logs\remote.log"

I tried comment out non-remote lines, but it's still the same.
I can also send you windows's dump file if you think that may help.

derick

2006-12-25 20:48

administrator   ~0000534

I tried on windows now, but I still can not reproduce it. Could you try the Xdebug dll from http://xdebug.org/link.php?url=xdebug200rc2-441-win to see if it works? If not, please provide the full output of weaver slaves' protocol window (including setting the breakpoints).

derick

2007-01-02 22:25

administrator   ~0000535

Reminder sent to sheepy

I tried on windows now, but I still can not reproduce it. Could you try the Xdebug dll from http://xdebug.org/link.php?url=xdebug200rc2-441-win to see if it works? If not, please provide the full output of weaver slaves' protocol window (including setting the breakpoints).

derick

2007-01-14 18:59

administrator   ~0000542

Reminder sent to sheepy

I tried on windows now, but I still can not reproduce it. Could you try the Xdebug dll from http://xdebug.org/link.php?url=xdebug200rc2-441-win to see if it works? If not, please provide the full output of weaver slaves' protocol window (including setting the breakpoints).

derick

2007-01-29 20:00

administrator   ~0000559

Reminder sent to sheepy

I tried on windows now, but I still can not reproduce it. Could you try the Xdebug dll from http://xdebug.org/link.php?url=xdebug200rc2-441-win to see if it works? If not, please provide the full output of weaver slaves' protocol window (including setting the breakpoints).

derick

2007-02-19 22:49

administrator   ~0000572

Reminder sent to sheepy

Last reminder:

I tried on windows now, but I still can not reproduce it. Could you try the Xdebug dll from http://xdebug.org/link.php?url=xdebug200rc3-441-win to see if it works? If not, please provide the full output of Weaverslaves' protocol window (including setting the breakpoints).

sheepy

2007-02-22 04:01

reporter   ~0000574

I tried rc3, and it seems to work fine. :) Thanks for your hard work and sorry for the inattention I was paying.

derick

2007-02-28 20:43

administrator   ~0000577

Fixed in CVS.

Issue History

Date Modified Username Field Change
2006-12-18 08:58 sheepy New Issue
2006-12-19 19:14 derick Note Added: 0000523
2006-12-19 19:14 derick Status new => feedback
2006-12-20 04:50 sheepy Note Added: 0000524
2006-12-25 20:48 derick Note Added: 0000534
2007-01-02 22:25 derick Note Added: 0000535
2007-01-14 18:59 derick Note Added: 0000542
2007-01-29 20:00 derick Note Added: 0000559
2007-02-19 22:49 derick Note Added: 0000572
2007-02-22 04:01 sheepy Note Added: 0000574
2007-02-28 20:43 derick Status feedback => closed
2007-02-28 20:43 derick Note Added: 0000577
2016-07-31 13:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 13:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)