View Issue Details

IDProjectCategoryView StatusLast Update
0000242XdebugUncategorizedpublic2007-02-20 08:44
ReporterAnt Assigned To 
PrioritynormalSeveritytrivialReproducibilityrandom
Status closedResolutionopen 
Summary0000242: Profiler files sometimes contain invalid numbers
DescriptionOccasionally I get values like these appearing in cachegrind.out* files:

fl=php:internal
fn=php::array_key_exists
38 4294967295

The 2^32-1 seems to be invalid as it's messing up the display in KCacheGrind. It happens every 20 or so page loads, and the function call seems to be unrelated - I see these happen for both internal and script functions.
Right now I'm manually editing these to 1 as a workaround but it'd be nice to have a fix.
Additional InformationUsing Apache 2.2.4, have tried using with a threaded and non-threaded MPM.
TagsNo tags attached.
Operating SystemGentoo 2006.1, x86
PHP Version5.2.0

Activities

derick

2007-02-20 08:44

administrator   ~0000573

I fixed this in CVS last night by removing the memory profiling, which obviously didn't work :). Please reopen if you can reproduce it still with the CVS version.

Issue History

Date Modified Username Field Change
2007-02-20 02:00 Ant New Issue
2007-02-20 08:44 derick Status new => closed
2007-02-20 08:44 derick Note Added: 0000573
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)
2020-03-12 16:35 derick Category Usage problems (Wrong Results) => Variable Display
2020-03-12 16:38 derick Category Variable Display => Uncategorized