View Issue Details

IDProjectCategoryView StatusLast Update
0000253XdebugUsage problems (Wrong Results)public2007-04-24 15:06
ReporterstanvAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000253: XDebug causes all error log messages to be trimmed at 1024 bytes, irrespective of "log_errors_max_len"
DescriptionIn the following code, the trace will be clipped at 1024 mark when xdebug is on, and will behave properly if xdebug is disabled in php.ini (no clipping):

<?php
error_reporting(E_ALL|E_STRICT);
ini_set('display_errors',0);
ini_set('log_errors',1);
ini_set('log_errors_max_len','0');
ini_set('html_errors',0);
ini_set('error_log','c:\log.txt');

function deepTrace($a, $b, $c) {
    if ($c < 50) {deepTrace($a, $b, $c+1);} else {throw new
Exception('Example exception that together with the trace is over 1024
bytes.');}
}
deepTrace('example','function',0);
?>
TagsNo tags attached.
Operating System
PHP Version5.2.1

Activities

derick

2007-04-23 16:24

administrator   ~0000591

I can't reproduce it - it works just fine here with apache 1.3.31 and PHP 5.2.2dev and the latest Xdebug from CVS.

stanv

2007-04-23 16:29

reporter   ~0000592

Derick, are you testing on windows? I mentioned I think in the bug this happens on Windows XP SP2 (and on Apache 2.2 in fact, I don't know if the Apache version matters).

derick

2007-04-24 15:06

administrator   ~0000594

Works fine for me on Windows 2k with Apache 1.3.29 as well - and there is no reason why things should be different here anyway.

Issue History

Date Modified Username Field Change
2007-04-10 16:16 stanv New Issue
2007-04-23 16:24 derick Status new => resolved
2007-04-23 16:24 derick Resolution open => unable to reproduce
2007-04-23 16:24 derick Assigned To => derick
2007-04-23 16:24 derick Note Added: 0000591
2007-04-23 16:29 stanv Status resolved => feedback
2007-04-23 16:29 stanv Resolution unable to reproduce => reopened
2007-04-23 16:29 stanv Note Added: 0000592
2007-04-24 15:06 derick Status feedback => resolved
2007-04-24 15:06 derick Resolution reopened => unable to reproduce
2007-04-24 15:06 derick Note Added: 0000594
2016-07-31 13:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 13:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)