View Issue Details

IDProjectCategoryView StatusLast Update
0000258XdebugInstallationpublic2007-05-27 23:26
ReporterpicklesAssigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary0000258: Unresolved OnUpdateBool when trying to load XDebug extension
DescriptionI've spent several hours trying to resolve this before posting it as a bug. I appreciate it when folks offer something to the open-source community and try to show that appreciation by being constructive. In the end if there is a quick solution and not a bug, maybe this will help other googler's out.

See Machine/PHP/XDebug configuration under "Additional Information".

After compliling & installing XDebug and adding the extension directive to php.ini I encounter the following errors:

Failed loading /usr/local/lib/php/20060613/xdebug.so: ld.so.1: php: fatal: relocation error: file /usr/local/lib/php/20060613/xdebug.so: symbol OnUpdateBool: referenced symbol not found
Failed loading /usr/local/lib/php/20060613/xdebug.so: ld.so.1: php: fatal: relocation error: file /usr/local/lib/php/20060613/xdebug.so: symbol OnUpdateBool: referenced symbol not found
PHP 5.2.0 (cli) (built: Apr 23 2007 19:58:59)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2006 Zend Technologies

The "closest" thing to this I could find on Google was problems with folks having "-enable-versioning" on when they compiled php. This setting is incompatible with a lot of extensions. I built PHP 5.2.0 from source and did not use this setting. Just to make sure I rebuilt php with disable-versioning.

I've also double checked to make sure that XDebug configure and make are using the "proper" php headers.
Additional InformationXDebug

./configure --enable-xdebug \
--with-php-config=/usr/local/bin/php-config

php.ini settings (have tried both ways)
; XDEBUG see: http://xdebug.org/install.php
zend_extension="/usr/local/lib/php/20060613/xdebug.so"
/extension=xdebug.so


php 5.2.0 configure options:

Build Date => Apr 23 2007 19:54:32
Configure Command => './configure' '--with-apxs=/usr/local/apache/bin/apxs' '--with-config-file-path=/usr/
local/etc/php' '--with-config-file-scan-dir=/usr/local/etc/php' '--enable-force-cgi-redirect' '--enable-fas
tcgi' '--disable-debug' '--disable-versioning' '--enable-inline-optimization' '--enable-memory-limit' '--en
able-so' '--enable-ctype' '--enable-dom' '--with-pcre-regex' '--enable-session' '--enable-simplexml' '--ena
ble-pear' '--with-layout=GNU' '--enable-exif' '--with-mcrypt' '--with-curl' '--enable-track-vars' '--with-c
alendar=shared' '--enable-calendar' '--enable-safe-mode' '--enable-magic-quotes' '--with-xml' '--enable-tra
ns-sid' '--enable-wddx' '--enable-ftp' '--enable-imap' '--with-mysql=/usr/local/mysql' '--with-zlib' '--wit
h-gd' '--enable-gd-native-ttf' '--with-freetype-dir=/usr/local' '--enable-gd-native-ttf' '--enable-gd-imgst
rttf' '--with-jpeg-dir=/usr/local' '--with-png-dir=/usr/local'
Server API => Command Line Interface
Virtual Directory Support => disabled
Configuration File (php.ini) Path => /data/software/etc/php/php.ini
Scan this dir for additional .ini files => /usr/local/etc/php
additional .ini files parsed => /usr/local/etc/php/php.ini

PHP API => 20041225
PHP Extension => 20060613
Zend Extension => 220060519
Debug Build => no
Thread Safety => disabled
Zend Memory Manager => enabled
IPv6 Support => enabled
Registered PHP Streams => php, file, data, http, ftp, compress.zlib
Registered Stream Socket Transports => tcp, udp, unix, udg
Registered Stream Filters => string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, co
nsumed, convert.iconv.*, zlib.*


This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.2.0, Copyright (c) 1998-2006 Zend Technologies

TagsNo tags attached.
Operating SystemSolaris 9: 5.9 Generic_118558-11 sun4u sparc SUNW,UltraAX-i2
PHP Version5.2.0

Activities

sniper

2007-05-09 16:04

reporter   ~0000607

Try using PHP 5.2.2 and latest CVS checkout of xdebug.
I can't reproduce this..as a side-note: check the configure options available in php configure with './configure --help'. There are couple that don't even exist anymore that you are using. :D

Also, you don't need these: '--disable-debug' '--disable-versioning'
Those are off by default.

I think you have either stale xdebug.so or php headers around in your system.
Otherwise I can't see why this would happen.

sniper

2007-05-12 04:11

reporter   ~0000611

Can you reproduce this in some other machine?

derick

2007-05-22 22:34

administrator   ~0000624

Reminder sent to pickles

Please provide the requested feedback.

pickles

2007-05-27 17:27

reporter   ~0000632

Please forgive me for taking so long to reply. I was out of town for awhile. When I upgraded to the latest PHP5 version I didn't have any problems.

derick

2007-05-27 23:26

administrator   ~0000633

Great, let's close the bug then.

Issue History

Date Modified Username Field Change
2007-04-24 18:11 pickles New Issue
2007-05-09 16:04 sniper Note Added: 0000607
2007-05-12 04:11 sniper Note Added: 0000611
2007-05-12 04:11 sniper Status new => feedback
2007-05-22 22:34 derick Note Added: 0000624
2007-05-27 17:27 pickles Note Added: 0000632
2007-05-27 23:26 derick Status feedback => closed
2007-05-27 23:26 derick Note Added: 0000633