View Issue Details

IDProjectCategoryView StatusLast Update
0000260XdebugUncategorizedpublic2007-05-28 16:24
Reporterdavidjustus Assigned To 
PrioritynormalSeveritymajorReproducibilityrandom
Status closedResolutionopen 
Summary0000260: Does not show error
DescriptionWhen xdebug is disabled we get the following error
Notice: Undefined property: list_fax_documents::$fax_status_id in /srv/www/unstable/localhost/postsale/_scripts/fax.datahandler.php on line 95

However when Xdebug was enabled we just got a blank page.

We were also able to get this to occur on another page these are what slandered php displays the errors as

Warning: accounts::include_once(import_log.datahandler.php) [function.accounts-include-once]: failed to open stream: No such file or directory in /srv/www/unstable/localhost/postsale/_scripts/accounts.datahandler.php on line 117

Warning: accounts::include_once() [function.include]: Failed opening 'import_log.datahandler.php' for inclusion (include_path='.:/usr/share/php5:/usr/share/php5/PEAR') in /srv/www/unstable/localhost/postsale/_scripts/accounts.datahandler.php on line 117

Fatal error: Class 'import_log' not found in /srv/www/unstable/localhost/postsale/_scripts/accounts.datahandler.php on line 1
Additional InformationThe HTML of the blank page looks like this
<html>
<head/>
<body>

</body>
</html>
TagsNo tags attached.
Operating SystemOpen SUSE - Apache prefork , php 5.27
PHP Version5.1.6

Activities

davidjustus

2007-04-27 13:20

reporter   ~0000603

Last edited: 2007-04-27 13:21

The problem appears to be reproducible. It only seems to occur when php outputs a notice or warning(anything non breaking), It seems that any of our scripts that output a notice crash with xdebug. The only solution i have found is to disable parameter tracing.

edited on: 2007-04-27 14:21

derick

2007-04-30 07:45

administrator   ~0000604

Could you please try Xdebug from CVS. I fixed quite a bit of problems that are available in RC3. See http://xdebug.org/install.php#source for instructions.

davidjustus

2007-05-01 23:18

reporter   ~0000605

I have upgraded to the CVS Version, this seems to have taken care of the issues, sorry for the inconvenience.

derick

2007-05-28 16:24

administrator   ~0000636

Great, let's close this report then.

Issue History

Date Modified Username Field Change
2007-04-26 23:59 davidjustus New Issue
2007-04-27 13:20 davidjustus Note Added: 0000603
2007-04-27 13:21 davidjustus Note Edited: 0000603
2007-04-30 07:45 derick Note Added: 0000604
2007-04-30 07:45 derick Status new => feedback
2007-05-01 23:18 davidjustus Note Added: 0000605
2007-05-28 16:24 derick Status feedback => closed
2007-05-28 16:24 derick Note Added: 0000636
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)
2020-03-12 16:35 derick Category Usage problems (Wrong Results) => Variable Display
2020-03-12 16:38 derick Category Variable Display => Uncategorized