View Issue Details

IDProjectCategoryView StatusLast Update
0000277XdebugUsage problems (Wrong Results)public2007-06-18 21:21
ReporterlarsAssigned To 
PrioritynormalSeveritytrivialReproducibilityalways
Status closedResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary0000277: xdebug.trace_output_name = "xdebug.%c" does not function as documented.
DescriptionIf i set the above option trace file names will be build like this: "trace.PID.xt".
According to http://xdebug.org/docs/all_settings it should be
like this trace.CRC32.xt.
TagsNo tags attached.
Operating SystemDebian 4.0 (Etch)
PHP Version5.2.0

Activities

derick

2007-05-30 00:01

administrator   ~0000641

That's not what the code says, the code is doing what the docs say:

case 'c': /* crc32 of the current working directory */
    VCWD_GETCWD(cwd, 127);
    xdebug_str_add(&fname, xdebug_sprintf("%lu", xdebug_crc32(cwd, strlen(cwd))), 1);
    break;

case 'p': /* pid */
    xdebug_str_add(&fname, xdebug_sprintf("%ld", getpid()), 1);
    break;

How do you see that the results are wrong?

lars

2007-05-30 00:27

reporter   ~0000642

Last edited: 2007-05-30 00:47

Thats strange. I have the following configuration option in the php.ini:
xdebug.trace_output_name = xdebug.%c and no overriding directives in any included apache config.

I restarted the apache and tried again:

 # ls -l trace*
 -rw-r--r-- 1 www-data www-data 94689 2007-05-30 00:22 trace.11061.xt
 -rw-r--r-- 1 www-data www-data 7940 2007-05-30 00:23 trace.11116.xt
 -rw-r--r-- 1 www-data www-data 352669 2007-05-30 00:25 trace.12604.xt

Thats the output.

I'm using the current cvs version and found the lines you quoted in usefulstuff.c, so i guess the error before. Maybe while parsing the configuration?

If i set "xdebug.trace_output_name = xdebug.%t" the same happens. The PID is used not the timestamp (->trace.12767.xt).

edited on: 2007-05-30 00:47

derick

2007-05-30 18:56

administrator   ~0000643

Strange, could you please check whether the settings that you make actually reflect in the output of phpinfo()? Although that wouldn't make sense as the default is crc32 as well. Could you also try the following:

xdebug.trace_output_name=xdebug.%c.%p

To add both options?

regards,
Derick

derick

2007-06-18 16:32

administrator   ~0000657

Reminder sent to lars

Could you please provide the requested feedback? (WIth the latest CVS version please)

lars

2007-06-18 21:17

reporter   ~0000658

Last edited: 2007-06-18 21:18

Sorry, i didn't noticed your request. phpinfo() confirmed my configuration.
I tried both
  xdebug.trace_output_name=xdebug.%c
  xdebug.trace_output_name=xdebug.%c.%p
and now both works. However on one virtual host i experience some strange segfaults with the apache since i updated. I will enquire and open a new bug report since this seems unrelated to this problem.

edited on: 2007-06-18 21:18

derick

2007-06-18 21:21

administrator   ~0000659

Let's close this one then - thanks for checking it out.

Issue History

Date Modified Username Field Change
2007-05-29 19:29 lars New Issue
2007-05-30 00:01 derick Note Added: 0000641
2007-05-30 00:01 derick Status new => feedback
2007-05-30 00:27 lars Note Added: 0000642
2007-05-30 00:47 lars Note Edited: 0000642
2007-05-30 18:56 derick Note Added: 0000643
2007-06-18 16:32 derick Note Added: 0000657
2007-06-18 21:17 lars Note Added: 0000658
2007-06-18 21:18 lars Note Edited: 0000658
2007-06-18 21:21 derick Status feedback => closed
2007-06-18 21:21 derick Note Added: 0000659
2016-07-31 13:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 13:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)