View Issue Details

IDProjectCategoryView StatusLast Update
0000300XdebugUsage problems (Wrong Results)public2007-10-28 18:13
ReporteremilsedghAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version 
Target VersionFixed in Version 
Summary0000300: Direction of Var_dump
Descriptionon Right To Left pages, when you get a Var_Dump, the results is almost unreadble.It will be nice if xdebugs adds 'direction:rtl;' to the Top Element of the var_dump result.
TagsNo tags attached.
Operating SystemKubuntu
PHP Version5.2.1

Activities

derick

2007-07-24 17:12

administrator   ~0000705

Don't you mean "direction: ltr" there?

emilsedgh

2007-07-24 17:16

reporter   ~0000706

oi!
yeah, 'direction: ltr;'
sorry for that :)

derick

2007-08-06 20:36

administrator   ~0000712

Fixed in CVS, thanks for your report.

emilsedgh

2007-09-09 12:14

reporter   ~0000723

I just compiled cvs, looks like its not fixed yet, could anyone confirm this?
this little test will show you that its fixed or not:

<div style="direction:rtl">
   <?php var_dump(array()); ?>
</div>

emilsedgh

2007-09-18 10:17

reporter   ~0000726

as I see, you added dir="ltr" but there is no attribute named 'dir' (thats just for <html> tag, AFAIK), please add style="direction: ltr;"
thanks

derick

2007-10-28 18:13

administrator   ~0000777

I had indeed forgotten the var_dump() - but not all the tables that were shown on errors. I checked the XHTML 1.0 specs, and "dir" can be used on table and pre as well. I therefore struck to them: http://www.w3.org/TR/xhtml1/dtds.html#dtdentry_xhtml1-strict.dtd_table defines %attr (http://www.w3.org/TR/xhtml1/dtds.html#dtdentry_xhtml1-strict.dtd_attrs), which includes %i18n; (http://www.w3.org/TR/xhtml1/dtds.html#dtdentry_xhtml1-strict.dtd_i18n) which defines "dir".

Issue History

Date Modified Username Field Change
2007-07-24 16:18 emilsedgh New Issue
2007-07-24 17:12 derick Note Added: 0000705
2007-07-24 17:12 derick Status new => feedback
2007-07-24 17:16 emilsedgh Note Added: 0000706
2007-08-06 20:36 derick Xdebug Version 2.0.0rc4 => 2.0.0
2007-08-06 20:36 derick Category Feature/Change request => Usage problems
2007-08-06 20:36 derick Status feedback => closed
2007-08-06 20:36 derick Note Added: 0000712
2007-09-09 12:14 emilsedgh Status closed => feedback
2007-09-09 12:14 emilsedgh Resolution open => reopened
2007-09-09 12:14 emilsedgh Note Added: 0000723
2007-09-18 10:17 emilsedgh Note Added: 0000726
2007-10-28 18:13 derick Status feedback => closed
2007-10-28 18:13 derick Note Added: 0000777
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)