View Issue Details

IDProjectCategoryView StatusLast Update
0000345XdebugUsage problems (Wrong Results)public2009-11-22 20:00
Reportermartin_cerhaAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000345: XDebug + external Javascript => crash with "... not defined." error
DescriptionWhen XDebug is active and I use external javascript in php
<script src="/include/calendar.js"></script>
where is defined some function or object (for examle Calendar). And when I try to use Calendar, system shows eror (translation):
Window title: Error
Text: Error in program. Do you want to debug? Line:58 Error: Calendar not defined.

Alert at the end of external script shows message successfully, and after that error...

When I rename the main file from .php to .htm, it works fine. Or when I stop XDebug (PHPEdit-Debug-XDebug-Stop XDebug listener) it works fine.
Additional InformationApache/2.2.4 (Win32) PHP/5.2.1
Opera/9.25 build 8827 (Windows NT 5.1; U; cs)
Internet Explorer 7.0.5730.13
TagsNo tags attached.
Operating SystemWin XP Pro Service Pack 2
PHP Version5.2.1

Activities

derick

2009-03-28 17:35

administrator   ~0000934

Please provide a copy of "view" source of the page that gives the javascript error.

Issue History

Date Modified Username Field Change
2007-12-29 23:50 martin_cerha New Issue
2009-03-28 17:35 derick Note Added: 0000934
2009-03-28 17:35 derick Status new => feedback
2009-11-22 20:00 derick Status feedback => resolved
2009-11-22 20:00 derick Resolution open => unable to reproduce
2009-11-22 20:00 derick Assigned To => derick
2016-07-31 13:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 13:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)