View Issue Details

IDProjectCategoryView StatusLast Update
0000374Xdebugpublic2008-07-04 09:37
Reporternirfri Assigned Toderick  
Status resolvedResolutionno change required 
Summary0000374: eclipse using xdebug, 2.0.3 & 2.1dev wont work
DescriptionI used 2.0.2 till now, I compiled it myself, all worked fine using eclipse.
I tried upgrading to 2.0.3 and the debugger would start.

below is the xdebug log
Additional Information<- feature_get -i 241 -n supports_async
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="" command="feature_get" transaction_id="241" feature_name="supports_async" supported="1"><![CDATA[0]]></response>

<- breakpoint_set -i 242 -t line -f file:///mnt/Licensing/licensing/login_backend.php -n 73
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="" command="breakpoint_set" transaction_id="242" id="147730001"></response>

<- run -i 243
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="" command="run" transaction_id="243" status="stopping" reason="ok"></response>
TagsNo tags attached.
Operating Systemfc7
PHP Version5.2.6



2008-07-04 09:37

administrator   ~0000862

This is a bug in the eclipse plugin - it is/was relying on broken behavior of Xdebug in the protocol.

Issue History

Date Modified Username Field Change
2008-05-26 10:49 nirfri New Issue
2008-07-04 09:37 derick Status new => resolved
2008-07-04 09:37 derick Resolution open => no change required
2008-07-04 09:37 derick Assigned To => derick
2008-07-04 09:37 derick Note Added: 0000862
2016-07-31 12:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 12:35 derick Category debugclient (debugging tool) => (No Category)