View Issue Details

IDProjectCategoryView StatusLast Update
0001029XdebugInstallationpublic2014-03-05 09:31
Reporterls5302Assigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Platformx64OSWindowsOS Version7
Product Version2.2.3 
Target VersionFixed in Version 
Summary0001029: Xdebug for PHP 5.5.8 fails to install
DescriptionI have successfully download and installed Xdebug 2.2.3 for PHP v5.4.25 from the following URLS:

http://windows.php.net/downloads/releases/php-5.4.24-Win32-VC9-x86.zip
http://xdebug.org/files/php_xdebug-2.2.3-5.4-vc9.dll

and adding the following to php.ini

zend_extension = ext\php_xdebug-2.2.3-5.4-vc9.dll

However, when I try and do exactly the same for PHP v5.5.8 XDebug does not get installed.

http://windows.php.net/downloads/releases/php-5.5.8-Win32-VC11-x86.zip
http://xdebug.org/files/php_xdebug-2.2.3-5.5-vc11.dll

zend_extension = ext\php_xdebug-2.2.3-5.5-vc11.dll

No errors, no indication on what is wrong, and no debug.
Steps To ReproduceInstall PHP 5.5.8 using the following link:

http://windows.php.net/downloads/releases/php-5.5.8-Win32-VC11-x86.zip

Download xdebug from:

http://xdebug.org/files/php_xdebug-2.2.3-5.5-vc11.dll

and add to the ext directory.

Add the following to php.ini:

zend_extension = ext\php_xdebug-2.2.3-5.5-vc11.dll

Run the following on command line:

php -m

and nothing happens.
Additional InformationThe downloads above are 32-bit.
TagsNo tags attached.
Operating SystemWindows 7 x64
PHP Version5.5.5-5.5.9

Activities

ls5302

2014-02-01 10:31

reporter   ~0002672

On closer inspection, it looks like the path for zend_extension takes account of the defined "extension" directory. So for my configuration zend_extension should be set to "php_xdebug-2.2.3-5.5-vc11.dll".

derick

2014-03-05 09:31

administrator   ~0002751

Yes, that changed in PHP 5.5, so I am closing this issue as "works as expected".

Issue History

Date Modified Username Field Change
2014-01-31 00:03 ls5302 New Issue
2014-02-01 10:31 ls5302 Note Added: 0002672
2014-03-05 09:31 derick Note Added: 0002751
2014-03-05 09:31 derick Status new => resolved
2014-03-05 09:31 derick Resolution open => no change required
2014-03-05 09:31 derick Assigned To => derick