View Issue Details

IDProjectCategoryView StatusLast Update
0001037XdebugUsage problems (Wrong Results)public2014-06-12 09:24
ReportermirkoAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformNetbeansOSWindows 7OS VersionUltimate SP1
Product Version2.2.3 
Target VersionFixed in Version 
Summary0001037: Error when stepping over require_once with relative path
DescriptionWhen stepping over a require_once, if it does not have the absolute path to the file, I get this error:

Warning: require_once(modelActivities.php): failed to open stream: No such file or directory in Unknown on line 0

Setting an absolute path solves the issue.
Steps To ReproduceSet a breakpoint or step over a line like this:

require_once('./myfile.php');
Additional InformationNetbeans v 7.4 or Netbeans v 8.0 RC1
Xdebug dll: php_xdebug-2.2.3-5.3-vc9.dll
PHP v 5.3.27
TagsNo tags attached.
Operating SystemWindows
PHP Version5.3.25-5.3.29

Activities

derick

2014-05-19 23:19

administrator   ~0002826

Xdebug doesn't change how paths works, and it just follows PHP. So I can't fix anything here (and neither can I reproduce it)

Issue History

Date Modified Username Field Change
2014-03-17 11:32 mirko New Issue
2014-05-19 23:19 derick Note Added: 0002826
2014-05-19 23:19 derick Status new => resolved
2014-05-19 23:19 derick Resolution open => unable to reproduce
2014-05-19 23:19 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)