View Issue Details

IDProjectCategoryView StatusLast Update
0001060XdebugUsage problems (Wrong Results)public2014-11-11 19:52
ReportercraigarnoAssigned Toderick 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformOpenSUSE 12.3 x64OSLinuxOS Version
Product Version2.2.5 
Target VersionFixed in Version 
Summary0001060: "I: Connected to client. :-)" but hasn't...
DescriptionI've spent 3 days working on this and need help...

Bottom line: I start a debug session in Firefox 24 ESR Windows 7 from Sync Custom Server - Create New Account using http://neptune/remote.php?XDEBUG_SESSION_START=netbeans-xdebug and see in
==> /var/log/xdebug.log <==
Log opened at 2014-07-05 23:43:47
I: Connecting to configured address/port: 192.168.90.7:10000.
I: Connected to client. :-)
-> <init xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" fileuri="file:///srv/www/htdocs/owncloud/remote.php" language="PHP" protocol_version="1.0" appid="2402" idekey="netbeans-xdebug/user/1.0/a"><engine version="2.2.5"><![CDATA[Xdebug]]></engine><author><![CDATA[Derick Rethans]]></author><url><![CDATA[http://xdebug.org]]></url><copyright><![CDATA[Copyright (c) 2002-2014 by Derick Rethans]]></copyright></init>

I then look at NetBeans 8 and it continues to say "Waiting For Connection (netbeans-xdebug)"

Windows 7: Only Firefox 24 ESR is running in Windows 7 192.168.90.186.

Linux: Apache, Netbeans, XDebug 2.2.5 (everything else) is running on a Linux Workstation (Neptune 192.168.90.7).


From phpinfo()

Apache/2.2.22 (Linux/SUSE)
PHP Version 5.5.14
XDebug Version 2.2.5
DBGp - Common DeBuGger Protocol $Revision: 1.145 $

/etc/php5/apache2/php.ini
[xdebug]
zend_extension = /usr/lib64/php5/extensions/xdebug.so

/etc/php5/conf.d/xdebug.ini
---------------------------
xdebug.remote_enable = On
xdebug.remote_handler = dbgp
xdebug.remote_host = 192.168.90.7
debug.remote_port = 10000
xdebug.remote_log = /var/log/xdebug.log
xdebug.allowed_clients = 192.168.90.7,neptune,neptune.arno.com,localhost,pluto.arno.com

http://xdebug.org/wizard.php reports:
Summary
Xdebug installed: 2.2.5
Server API: Apache 2.0 Handler
Windows: no
Zend Server: no
PHP Version: 5.5.14
Zend API nr: 220121212
PHP API nr: 20121212
Debug Build: no
Thread Safe Build: no
Configuration File Path: /etc/php5/apache2
Configuration File: /etc/php5/apache2/php.ini
Extensions directory: /usr/lib64/php5/extensions

NetBeans:
========
Product Version: NetBeans IDE 8.0 (Build 201403101706)
Updates: NetBeans IDE is updated to version NetBeans 8.0 Patch 2
Java: 1.7.0_51; OpenJDK 64-Bit Server VM 24.45-b08
Runtime: OpenJDK Runtime Environment 1.7.0_51-b00
System: Linux version 3.7.10-1.36-desktop running on amd64; UTF-8; en_US (nb)
User directory: /local/craig/.netbeans/8.0
Cache directory: /local/craig/.cache/netbeans/8.0

I also tried debug of a small info.html which calls phpinfo(). This also doesn't work from Windows 7 Firefox 24 ESR or OpenSUSE Linux 12.3 x64 Firefox 30.

Consider me a PHP / NetBeans / XDebug "newbie" who has 30 years of development experience in other areas.
Steps To ReproduceSTEP 1:
Start NetBeans 8 "Debug Project" after configuring Tools -> Options -> PHP -> Debugging:
Debugger Port: 10000
Session ID: netbeans-xdebug
Check "Stop at First Line"
PHP putput_buffering = Off (in php.ini)

STEP 2:
In Firefox submit URL http://neptune.arno.com/info.php?XDEBUG_SESSION_START=netbeans-xdebug
(substitute your server for neptune.arno.com)
 
 info.php
 ========
<html>
<head>
    <title>PHP Test</title>
    <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">
</head>
<body>
    <h1>PHP Test</h1>
    


    An Example of PHP in Action

        <?php echo "The Current Date and Time is:
";
            echo date("g:i A l, F j Y.");?>
    



    <h2>PHP Information</h2>
    


        <?php phpinfo(); ?>
    


</body>
</html>

Set breakpoint on Line 0000010 "<?php echo "The Current Date and Time is:
";"
Additional InformationXDebug 2.2.5 is installed from the release 2.2.5 XDebug package xdebug-2.2.5.tgz

Steps from http://xdebug.org/docs/install were followed. Successive attempts followed steps from http://xdebug.org/wizard.php
TagsNo tags attached.
Operating SystemOpenSUSE Linux 12.3 x64
PHP Version5.5.5-5.5.9

Activities

craigarno

2014-07-08 16:45

reporter   ~0002859

Last edited: 2014-07-12 01:35

View 2 revisions

I used GIT to download/install xdebug 2.3.0dev from the date/time stamp on this note.

After restarting NetBeans 8, my setup has worked -once- and is still working against both Firefox 24 ESR Windows and Firefox 30 Linux with the configuration listed above. Since this configuration worked intermittently before with 2.2.5 release I'm reluctant to shut it down and retry until I can get a few more things accomplished with this working instance.

When it works, it's great! (just what I need)

10-Jul
======
I am able to get XDebug 2.3.0-dev working by following these steps:

 1. Sometimes all that's needed is to restart NetBeans 8.

 2. Other times I have to restart the Apache 2.2 server (which restarts XDebug) then restart NetBeans 8 to restore PHP debug operation.

This is with OpenSUSE 12.3 x64 and the restart command "/etc/init.d/apache2 restart"

So far one or the other of these steps has worked almost 100% of the time, maybe one or two times it took 2 restarts. This is more reliable than 2.2.5.

derick

2014-11-11 19:52

administrator   ~0002902

When Xdebug says it has connected, it really has. TCP does not lie. What is
most likely is that your IDE does something wonky. Netbeans insists on correct
path mappings and an opened projected as far as I know. If things are
unstable, it is very likely Netbeans' doing. And hence, I can not help.

Issue History

Date Modified Username Field Change
2014-07-06 01:07 craigarno New Issue
2014-07-08 16:45 craigarno Note Added: 0002859
2014-07-12 01:35 craigarno Note Edited: 0002859 View Revisions
2014-11-11 19:52 derick Note Added: 0002902
2014-11-11 19:52 derick Status new => resolved
2014-11-11 19:52 derick Resolution open => unable to reproduce
2014-11-11 19:52 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)