View Issue Details

IDProjectCategoryView StatusLast Update
0001074XdebugUsage problems (Wrong Results)public2014-08-28 16:45
ReporterAlexanderRVAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
Product Version2.2.4 
Target VersionFixed in Version 
Summary0001074: enabled show_exception_trace causes exception to be shown for caught statements
DescriptionConfiguration option
xdebug.show_exception_trace = 1
disregards whether exception was caught or not.
Always showing the exception trace interrupting output flow.
Steps To Reproducefunction exceptionTest() {
    throw new \Exception();
}

try {
    exceptionTest();
} catch (\Exception $e) {
    echo "caught exception";
}
TagsNo tags attached.
Operating SystemCentos 6
PHP Version5.4.15-5.4.20

Activities

AlexanderRV

2014-08-28 16:04

reporter   ~0002878

PHP Version is meant to be 5.5.x NOT 5.4, sorry.

derick

2014-08-28 16:45

administrator   ~0002879

Hi!

This is by design. It's documented at http://xdebug.org/docs/all_settings#show_exception_trace as well. If you only want to see traces for uncaught exceptions, just leave this setting to its default of 0.

cheers,
Derick

Issue History

Date Modified Username Field Change
2014-08-28 16:02 AlexanderRV New Issue
2014-08-28 16:04 AlexanderRV Note Added: 0002878
2014-08-28 16:45 derick Note Added: 0002879
2014-08-28 16:45 derick Status new => resolved
2014-08-28 16:45 derick Resolution open => no change required
2014-08-28 16:45 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)