View Issue Details

IDProjectCategoryView StatusLast Update
0001078XdebugInstallationpublic2014-11-11 19:50
ReportersjalmondAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionnot fixable 
PlatformLinuxOSUbuntuOS Version14.04.01
Product Version2.2.1 
Target VersionFixed in Version 
Summary0001078: PEAR doesn't register upgrade to 2.2.5
DescriptionI don't know if this is an xdebug, PECL, or PEAR error - but hopefully you do!

Upgrade from xdebug 2.2.1 to 2.2.5 with PEAR succeeds, but the upgrade still shows as to-do.

First: list upgrades

$ sudo pear list-upgrades
[snip]
pecl.php.net Available Upgrades (stable):
=========================================
Channel Package Local Remote Size
pecl.php.net xdebug 2.2.1 (stable) 2.2.5 (stable) 250kB

$ sudo pear upgrade
Starting to download xdebug-2.2.5.tgz (255,840 bytes)
[snip]
148132 924 -rwxr-xr-x 1 root root 938213 Oct 16 10:33 /tmp/pear/install/pear-bui ld-rootUsv7L4/install-xdebug-2.2.5/usr/lib/php5/20121212/xdebug.so

Build process completed successfully
Installing '/usr/lib/php5/20121212/xdebug.so'


$ sudo pear list-upgrades
[snip]
pecl.php.net Available Upgrades (stable):
=========================================
Channel Package Local Remote Size
pecl.php.net xdebug 2.2.1 (stable) 2.2.5 (stable) 250kB
Steps To ReproduceInstall xdebug using PEAR
sudo pear list-upgrades (shows xdebug 2.2.1->2.2.5)
sudo pear upgrade (shows upgrade to 2.2.5 successful)
sudo pear list-upgrades (shows xdebug 2.2.1->2.2.5)
Additional Information$ php --re xdebug
Extension [ <persistent> extension 0000056 xdebug version 2.2.5 ] {
[snip]


~$ php --version
PHP 5.5.9-1ubuntu4.4 (cli) (built: Sep 4 2014 06:56:34)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2014 Zend Technologies
    with Zend OPcache v7.0.3, Copyright (c) 1999-2014, by Zend Technologies
    with Xdebug v2.2.5, Copyright (c) 2002-2014, by Derick Rethans
Tagspear, pecl, upgrade
Operating SystemUbuntu 14.04.1
PHP Version5.5.5-5.5.9

Activities

derick

2014-11-11 19:50

administrator   ~0002899

This is not something that Xdebug does, so the problem would be in PEAR/PECL.
I am going to guess that this is because of some cache though. Try emptying
out PEAR's cache in /tmp/pear. In any case, I am closing this as this is an
issue with the installer that I have no influence over (and I can also not
reproduce this).

Issue History

Date Modified Username Field Change
2014-10-16 09:58 sjalmond New Issue
2014-10-16 09:58 sjalmond Tag Attached: pecl
2014-10-16 09:59 sjalmond Tag Attached: pear
2014-10-16 09:59 sjalmond Tag Attached: upgrade
2014-11-11 19:50 derick Note Added: 0002899
2014-11-11 19:50 derick Status new => resolved
2014-11-11 19:50 derick Resolution open => not fixable
2014-11-11 19:50 derick Assigned To => derick