View Issue Details

IDProjectCategoryView StatusLast Update
0001086XdebugUsage problems (Wrong Results)public2015-02-06 23:31
ReporterdeepedAssigned Toderick 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
PlatformPhp XdebugOSWindowsOS Version7
Product Version2.2.5 
Target VersionFixed in Version 
Summary0001086: xdebug_get_code_coverage() returns more sources even it has just started
DescriptionIm in the middle of a framework, so its not a plain php script. This is all I got:

xdebug_start_code_coverage (XDEBUG_CC_UNUSED | XDEBUG_CC_DEAD_CODE);
xdebug_stop_code_coverage(true);
xdebug_start_code_coverage (XDEBUG_CC_UNUSED | XDEBUG_CC_DEAD_CODE);
xdebug_stop_code_coverage(true);
xdebug_start_code_coverage (XDEBUG_CC_UNUSED | XDEBUG_CC_DEAD_CODE);
xdebug_stop_code_coverage(true);
var_dump (xdebug_get_code_coverage());

interestingly, it outputs that other scripts had also run. I thought it reports lines between xdebug_start_code_coverage() and xdebug_stop_code_coverage()
TagsNo tags attached.
Operating System
PHP Version5.5.5-5.5.9

Activities

deeped

2014-11-16 12:24

reporter   ~0002912

nevermind, I delete this ticket, I will post another with better explanation

derick

2014-11-27 20:56

administrator   ~0002917

I can't reproduce that with a simple script, so I am going to need a reproducible case from you I'm afraid.

derick

2015-01-07 15:59

administrator   ~0002964

I can't reproduce this, and no feedback was received. Please reopen if this is still an issue with 2.2.6.

deeped

2015-01-07 17:01

reporter   ~0002965

I already said nevermind this topic, I posted another with better explanation

derick

2015-02-06 23:31

administrator   ~0002980

Oh - I missed that. Sorry. Closing this one then.

Issue History

Date Modified Username Field Change
2014-11-14 23:33 deeped New Issue
2014-11-16 12:24 deeped Note Added: 0002912
2014-11-27 20:56 derick Note Added: 0002917
2014-11-27 20:56 derick Assigned To => derick
2014-11-27 20:56 derick Status new => feedback
2015-01-07 15:59 derick Note Added: 0002964
2015-01-07 15:59 derick Status feedback => resolved
2015-01-07 15:59 derick Resolution open => unable to reproduce
2015-01-07 17:01 deeped Note Added: 0002965
2015-01-07 17:01 deeped Status resolved => feedback
2015-01-07 17:01 deeped Resolution unable to reproduce => reopened
2015-02-06 23:31 derick Note Added: 0002980
2015-02-06 23:31 derick Status feedback => resolved
2015-02-06 23:31 derick Resolution reopened => no change required
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)