View Issue Details

IDProjectCategoryView StatusLast Update
0001125XdebugUsage problems (Wrong Results)public2017-02-07 17:11
ReportersSaschaAssigned Toderick 
PriorityurgentSeverityblockReproducibilityalways
Status resolvedResolutionno change required 
PlatformApache Zend Server 8OSOSXOS Version10.10.2
Product Version2.3.1 
Target VersionFixed in Version 
Summary0001125: XDEBUG not working with Zends Zray
DescriptionIf you disable the Zend debugger and use Xdebug instead.
The following Problems occure:
The Debug session will always start @ zray.php
If you disable zray it's the same.

What zend does with there debugger: They seem to disable zray for the debug session. So it could be a zend problem or a xdebug feature/workaround.
Steps To Reproduce- Install ZendServer 8
- Install xdebug (pecl)
- Disable the zend debugger and add the extension.
- A IDE i use PHPSTORM
- Listen for incomming debug requests
- Create a file index.php add a breakpoint
- Reload the page it will not break @ index.php -> It looks like zray is loaded before any request on the same host (localhost) with the same php.ini and thats a problem for xdebug.
TagsNo tags attached.
Operating System
PHP Version5.4.10-5.4.14

Activities

derick

2016-11-29 23:54

administrator   ~0003856

Is this still a problem for you?

jvandijk

2016-12-19 11:33

reporter   ~0004083

Last edited: 2016-12-19 12:25

View 2 revisions

Hey Derick, this problem still exists. From Zend Server 8.5 and on XDebug comes bundled. If you enable Z-Ray in combination with XDebug and start a remote debug session it will always halt execution in zray.php first when using the break at first line logic.

Due to Z-Ray, the break at first line logic will render unexpected debug behaviour. Disabling the break at first line functionality, and using normal breakpoints does work properly.

derick

2016-12-19 12:01

administrator   ~0004086

If this is their auto_prepend file, or something similar through an extension, there is little I can do about this. The "break at first line" is functionality provided by an IDE - perhaps you can convince them to not stop at a first line if the file is zray.php?

jvandijk

2016-12-19 12:38

reporter   ~0004088

No it's an iframe that runs on the same domain. The question is: because it's an iframe should I see 2 debug calls or not?

PHPStorm offers 'skip' Z-Ray functionality indeed for the Zend Debugger, just not for XDebug.

derick

2016-12-19 12:44

administrator   ~0004089

Yes, you should see two calls. PhpStorm *does* support multiple simultaneous debugging connections, but you need to turn that on at Languages & Frameworks ? PHP ? Debug ? External Connections ? Max. simultaneous connections.

If you increase that from 1 to something higher, you should get two debugging sessions. I would ask PhpStorm to also allow the "Ignore Z-Ray system requests" flag to work for Xdebug - they have an issue tracker at https://youtrack.jetbrains.com

sSascha

2016-12-19 12:44

reporter   ~0004090

Thx jvandijk for stepping in. I'm currently far away from php more in .net and javascript.

@derick:
Yes the problem is phpstorm offers to disable zray for debug sessions. I hope you can find a solution... probably talking to the guys from jetbrains or zend?

derick

2016-12-19 18:37

administrator   ~0004092

(Flipping this back to Feedback to allow @jvandijk to give feedback on the simultaneous connections setting in PhpStorm)

derick

2017-01-10 14:22

administrator   ~0004169

@jvandijk ?

derick

2017-02-07 17:11

administrator   ~0004203

I am closing this, as this does not seem to be a bug in Xdebug. Please feel free to reopen this if you can provide more information as requested.

Issue History

Date Modified Username Field Change
2015-03-06 11:29 sSascha New Issue
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)
2016-11-29 23:54 derick Note Added: 0003856
2016-11-29 23:54 derick Assigned To => derick
2016-11-29 23:54 derick Status new => feedback
2016-12-19 11:33 jvandijk Note Added: 0004083
2016-12-19 12:01 derick Note Added: 0004086
2016-12-19 12:25 jvandijk Note Edited: 0004083 View Revisions
2016-12-19 12:38 jvandijk Note Added: 0004088
2016-12-19 12:44 derick Note Added: 0004089
2016-12-19 12:44 sSascha Note Added: 0004090
2016-12-19 12:44 sSascha Status feedback => assigned
2016-12-19 18:37 derick Note Added: 0004092
2016-12-19 18:37 derick Status assigned => feedback
2017-01-10 14:22 derick Note Added: 0004169
2017-02-07 17:11 derick Note Added: 0004203
2017-02-07 17:11 derick Status feedback => resolved
2017-02-07 17:11 derick Resolution open => no change required