View Issue Details

IDProjectCategoryView StatusLast Update
0001149XdebugInstallationpublic2015-05-12 23:20
ReportersokadaAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
PlatformMacBook ProOSOSX YosemiteOS Version10.10.3
Product Version2.3.2 
Target VersionFixed in Version 
Summary0001149: Xdebug requires Zend Engine API version 220121212.
DescriptionI just installed php5.6.7. I run a command, php -v then I get the followings.

Xdebug requires Zend Engine API version 220121212.
The Zend Engine API version 220131226 which is installed, is newer.
Contact Derick Rethans at http://xdebug.org/docs/faq#api for a later version of Xdebug.

PHP 5.6.7 (cli) (built: May 8 2015 21:46:09)
Copyright (c) 1997-2015 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2015 Zend Technologies
TagsNo tags attached.
Operating System
PHP Version5.6.5-5.6.9

Activities

sokada

2015-05-09 07:51

reporter   ~0003078

I had php5.5 and I had no problem with installing xdebug. I installed php56 with homebrew.

I followed this from http://xdebug.org/wizard.php.

Download xdebug-2.3.2.tgz
Unpack the downloaded file with tar -xvzf xdebug-2.3.2.tgz
Run: cd xdebug-2.3.2
Run: phpize (See the FAQ if you don't have phpize.

As part of its output it should show:

Configuring for:
...
Zend Module Api No: 20131226
Zend Extension Api No: 220131226
If it does not, you are using the wrong phpize. Please follow this FAQ entry and skip the next step.

Run: ./configure
Run: make
Run: cp modules/xdebug.so /usr/local/Cellar/php56/5.6.7/lib/php/extensions/no-debug-non-zts-20131226
Edit /usr/local/etc/php/5.6/php.ini and add the line
zend_extension = /usr/local/Cellar/php56/5.6.7/lib/php/extensions/no-debug-non-zts-20131226/xdebug.so
Restart the webserver

sokada

2015-05-09 07:52

reporter   ~0003079

There is no sign of xdebug in phpinfo.php.

derick

2015-05-12 23:20

administrator   ~0003085

This is not a bug, you're likely just doing something wrong. Please contact the mailinglist for support - as this is an issue (bug) tracker. See http://xdebug.org/support.php

Issue History

Date Modified Username Field Change
2015-05-09 07:49 sokada New Issue
2015-05-09 07:51 sokada Note Added: 0003078
2015-05-09 07:52 sokada Note Added: 0003079
2015-05-12 23:20 derick Note Added: 0003085
2015-05-12 23:20 derick Status new => resolved
2015-05-12 23:20 derick Resolution open => no change required
2015-05-12 23:20 derick Assigned To => derick