View Issue Details

IDProjectCategoryView StatusLast Update
0001169XdebugUsage problems (Wrong Results)public2015-11-20 18:03
Reporterkchan4Assigned Toderick 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
PlatformLinuxOSCentosOS Version6.5
Product Version2.3.2 
Target VersionFixed in Version 
Summary0001169: xDebug not stopping at breakpoint
DescriptionI've been searching in google and stackoverflow for hours.....didn't find a reason...

I have my app hosted in a Centos 6.5 Apache and debugging from my dev machine with Visual Studio + PHP Tools.

It was working prefectly fine until I did some update, restart, couchdb install/configuration (and a lot of other things) to the Centos machine, then I notice the xdebug doesn't stop at breakpoint anymore, it only stops if there is exception or I write out xdebug_break() in the PHP script...

I tried disable SELinux, Iptables, it doesn't help as well.

Then I looked at the xdebug.log file, it gives me random error as follows:

I: Connected to client. :-)
-> <init xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" fileuri="file:///home/ec2-user/webapps/webapps/PVPCardGame/index.php" language="PHP" protocol_version="1.0" appid="$

<- breakpoint_set -i x0-10000 -t exception -x "Fatal error"
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="breakpoint_set" transaction_id="x0-10000" id="39890001"></response>

<- breakpoint_set -i x1-10001 -t exception -x "Parse error"
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="breakpoint_set" transaction_id="x1-10001" id="39890002"></response>

<- breakpoint_set -i x2-10002 -t exception -x "Unknown error"
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="breakpoint_set" transaction_id="x2-10002" id="39890003"></response>

<- feature_get -i 3 -n max_children
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_get" transaction_id="3" feature_name="max_children" supported="1"><![CDATA[32]]></response>

<- breakpoint_set -i 4-0 -t line -f file:///home/ec2-user/webapps/webapps/PVPCardGame_fuel/app/classes/controller/user.php -n 104
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="breakpoint_set" transaction_id="4-0" id="39890004"></response>

<- breakpoint_set -i 5-1 -t line -f file:///home/ec2-user/webapps/webapps/PVPCardGame_fuel/app/classes/controller/user.php -n 108
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="breakpoint_set" transaction_id="5-1" id="39890005"></response>
So it does connected to my client, but I have zero idea from what error log...

XDebug Version 2.3.2 PHP Version 5.4.41
Steps To ReproduceNo idea.....
TagsNo tags attached.
Operating System
PHP Version5.4.4

Activities

derick

2015-06-25 13:38

administrator   ~0003134

Can you try debugging with a small script? And provide the full xdebug remote log file? (Feel free to remove it first, to remove the stuff that's already in there)

kchan4

2015-06-26 01:35

reporter  

xdebug.log (2,823 bytes)

kchan4

2015-06-26 01:39

reporter   ~0003140

I created an empty project, only contain a single index.php which does the following (also shown in screenshoot):
<?php

$a = 1;
$b = 2;
$c = $a + $b;

echo 'Result: ' + $c;

xdebug_break();

?>
Its only break on the line 9, which is xdebug_break(), but not on the line 5 and 7....

kchan4

2015-06-26 01:39

reporter  

visualstudio_php_code.png (58,582 bytes)
visualstudio_php_code.png (58,582 bytes)

kchan4

2015-06-26 01:44

reporter   ~0003141

Just in case, my php.ini extension are follows, which I hadn't changed since the day it was working:

zend_extension=/usr/lib64/php/modules/xdebug.so
;extension=xdebug.so
xdebug.remote_log="/tmp/xdebug.log"
xdebug.profiler_enable = 1
xdebug.remote_enable=on
;xdebug.remote_host=10.197.15.61
;xdebug.remote_host=10.197.9.59
xdebug.remote_port=9000
xdebug.remote_autostart=1
xdebug.idekey=php-vs
xdebug.remote_handler=dbgp
xdebug.remote_mode=req
xdebug.remote_connect_back=On

Also phpInfo()

xdebug

xdebug support enabled
Version 2.3.2
IDE Key 97C383C0

Supported protocols Revision
DBGp - Common DeBuGger Protocol $Revision: 1.145 $

Directive Local Value Master Value
xdebug.auto_trace Off Off
xdebug.cli_color 0 0
xdebug.collect_assignments Off Off
xdebug.collect_includes On On
xdebug.collect_params 0 0
xdebug.collect_return Off Off
xdebug.collect_vars Off Off
xdebug.coverage_enable On On
xdebug.default_enable On On
xdebug.dump.COOKIE no value no value
xdebug.dump.ENV no value no value
xdebug.dump.FILES no value no value
xdebug.dump.GET no value no value
xdebug.dump.POST no value no value
xdebug.dump.REQUEST no value no value
xdebug.dump.SERVER no value no value
xdebug.dump.SESSION no value no value
xdebug.dump_globals On On
xdebug.dump_once On On
xdebug.dump_undefined Off Off
xdebug.extended_info On On
xdebug.file_link_format no value no value
xdebug.force_display_errors Off Off
xdebug.force_error_reporting 0 0
xdebug.halt_level 0 0
xdebug.idekey php-vs php-vs
xdebug.max_nesting_level 256 256
xdebug.max_stack_frames -1 -1
xdebug.overload_var_dump On On
xdebug.profiler_aggregate Off Off
xdebug.profiler_append Off Off
xdebug.profiler_enable On On
xdebug.profiler_enable_trigger Off Off
xdebug.profiler_enable_trigger_value no value no value
xdebug.profiler_output_dir /tmp /tmp
xdebug.profiler_output_name cachegrind.out.%p cachegrind.out.%p
xdebug.remote_autostart On On
xdebug.remote_connect_back On On
xdebug.remote_cookie_expire_time 3600 3600
xdebug.remote_enable On On
xdebug.remote_handler dbgp dbgp
xdebug.remote_host localhost localhost
xdebug.remote_log /tmp/xdebug.log /tmp/xdebug.log
xdebug.remote_mode req req
xdebug.remote_port 9000 9000
xdebug.scream Off Off
xdebug.show_exception_trace Off Off
xdebug.show_local_vars Off Off
xdebug.show_mem_delta Off Off
xdebug.trace_enable_trigger Off Off
xdebug.trace_enable_trigger_value no value no value
xdebug.trace_format 0 0
xdebug.trace_options 0 0
xdebug.trace_output_dir /tmp /tmp
xdebug.trace_output_name trace.%c trace.%c
xdebug.var_display_max_children 128 128
xdebug.var_display_max_data 512 512
xdebug.var_display_max_depth 3 3

kchan4

2015-08-18 07:59

reporter   ~0003161

I got it working by uninstall PHP Version 5.4.41 from my Centos machine and reinstall PHP 5.5.27 (php55u).

I am not sure, but probably is because how xDebug works. Its first interpret in Centos's PHP 5.4.41 and send debug information to my local windows machine which runs PHP 5.6.8 and interpret the debug information with my source code.

Maybe that's why it won't stop at breakpoint I provided in IDE?

derick

2015-11-20 18:03

administrator   ~0003248

I think it could have to do with file name cases on the file system. I've improved this in later Xdebug versions so perhaps that's what it is. I am closing this one out, as it seems you've resolved it for your use case.

Issue History

Date Modified Username Field Change
2015-06-25 09:20 kchan4 New Issue
2015-06-25 13:38 derick Note Added: 0003134
2015-06-25 13:38 derick Assigned To => derick
2015-06-25 13:38 derick Status new => feedback
2015-06-26 01:35 kchan4 File Added: xdebug.log
2015-06-26 01:39 kchan4 Note Added: 0003140
2015-06-26 01:39 kchan4 Status feedback => assigned
2015-06-26 01:39 kchan4 File Added: visualstudio_php_code.png
2015-06-26 01:44 kchan4 Note Added: 0003141
2015-08-18 07:59 kchan4 Note Added: 0003161
2015-11-20 18:03 derick Note Added: 0003248
2015-11-20 18:03 derick Status assigned => resolved
2015-11-20 18:03 derick Resolution open => no change required
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)