View Issue Details

IDProjectCategoryView StatusLast Update
0001170XdebugFeature/Change requestpublic2015-11-19 16:07
ReporterstofAssigned Toderick 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0001170: Provide a way to disable the path coverage
DescriptionPHPUnit with code coverage is way slower on XDebug 2.3 than on 2.2 (see http://bugs.xdebug.org/view.php?id=1123 for the report).
My guess is that this is related to the fact that XDebug 2.3 computes the path coverage, not only the line coverage. However, PHPUnit is currently not able to process this information. This means that we are currently doing lots of useless coverage computation.

Having an option to tell XDebug that we don't need the path coverage would be great. PHPUnit could then use it until it supports rendering this path coverage.
TagsNo tags attached.
Operating System
PHP Version5.6.0-5.6.4

Activities

derick

2015-06-25 13:34

administrator   ~0003132

It shouldn't do that, but it's possible I got an if() wrong, or missing, somewhere so that it does more work than it needs.

stof

2015-06-25 13:38

developer   ~0003133

Well, is there actually a way to disable branch coverage ? I don't see anything about this in the doc: http://xdebug.org/docs/code_coverage

derick

2015-11-09 02:03

administrator   ~0003215

I think this should be a lot better in Xdebug 2.4.0beta1 due to https://github.com/xdebug/xdebug/commit/38f72a294d86dfb86e8789911b0b1a827d9e1fe9 — could you please test with Xdebug (latest from GIT master)?

Maks3w

2015-11-09 08:49

reporter   ~0003217

Side note:

* Path coverage is enabled with XDEBUG_CC_BRANCH_CHECK flag https://github.com/xdebug/xdebug.org/pull/23.

* PHPUnit will support path coverage https://github.com/sebastianbergmann/php-code-coverage/pull/400

derick

2015-11-19 16:07

administrator   ~0003235

I am closing this, as path coverage specifically needs to be turned on. There was a bug that always caused path coverage to be enabled, but that should be fixed in 2.4.0beta1.

Issue History

Date Modified Username Field Change
2015-06-25 12:27 stof New Issue
2015-06-25 13:34 derick Note Added: 0003132
2015-06-25 13:38 stof Note Added: 0003133
2015-11-09 02:03 derick Note Added: 0003215
2015-11-09 08:49 Maks3w Note Added: 0003217
2015-11-19 16:07 derick Note Added: 0003235
2015-11-19 16:07 derick Status new => resolved
2015-11-19 16:07 derick Resolution open => no change required
2015-11-19 16:07 derick Assigned To => derick