View Issue Details

IDProjectCategoryView StatusLast Update
0001172XdebugRemote Debuggingpublic2017-01-03 18:55
Reportertien.xuan.voAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformApache 2.4.12OSLinuxOS VersionLubuntu 14.04
Product Version2.3.3 
Target VersionFixed in Version 
Summary0001172: Socket exception occured while traveling through call stack
DescriptionSet a break point, then start debugging. When the code is paused, click at a point in call stack, and a socket exception occured.
Steps To Reproduce1. Clone code from this repo https://github.com/tienvx/xdebug-reproduce and create a virtual host to that code.
2. Create a netbeans project
3. Set a break point at line 8 function_5($arg2->name);
4. Start debugging.
5. When the code is paused, open call stack window, and double click on the line index.php.Class1::method3:18
6 A socket exception occured.
Additional Information1. PHP 5.6.10
2. Xdebug 2.3.3
3. Netbeans 7.2.1
4. I put code in another host in the same network.
5. Here is the xdebug configs:
;/etc/php5/mods-available/xdebug.ini
zend_extension=xdebug.so

[xdebug]
xdebug.remote_host=192.168.1.104
;xdebug.remote_connect_back=1
xdebug.remote_enable=1
xdebug.remote_autostart=0
xdebug.remote_cookie_expire_time=86400
xdebug.remote_port=9000
xdebug.idekey=”netbeans-xdebug”
xdebug.profiler_enable=0
xdebug.profiler_enable_trigger=1
TagsNo tags attached.
Operating SystemUbuntu Server 14.04
PHP Version5.1.0

Activities

tien.xuan.vo

2015-07-02 04:36

reporter  

reproduce.png (76,720 bytes)
reproduce.png (76,720 bytes)

tien.xuan.vo

2015-07-02 04:38

reporter  

error.png (41,196 bytes)
error.png (41,196 bytes)

tien.xuan.vo

2015-07-02 04:41

reporter  

exception.png (12,279 bytes)
exception.png (12,279 bytes)

derick

2015-07-02 08:52

administrator   ~0003144

Hi! Thanks for the report? Would it be possible to create a debugging log to go with your reproducible case? You can do so by setting xdebug.remote_log=/tmp/xdebug.log -- and then attach that file to this report. This prevents me from having to install and learn Netbeans :-)

tien.xuan.vo

2015-07-11 01:24

reporter   ~0003149

Sorry for late response! Here is the log.

tien.xuan.vo

2015-07-11 01:25

reporter  

xdebug.log (54,955 bytes)

derick

2016-12-12 00:14

administrator   ~0004028

Is this still a problem for you with the latest Xdebug (2.5.0)? And which version of PHP are you using? Your report says PHP 5.1.0.

derick

2017-01-03 18:55

administrator   ~0004139

I could not reproduce this, and no feedback was given. I'm closing this issue, but feel free to reopen if this happens again.

Issue History

Date Modified Username Field Change
2015-07-02 04:36 tien.xuan.vo New Issue
2015-07-02 04:36 tien.xuan.vo File Added: reproduce.png
2015-07-02 04:38 tien.xuan.vo File Added: error.png
2015-07-02 04:41 tien.xuan.vo File Added: exception.png
2015-07-02 08:52 derick Note Added: 0003144
2015-07-02 08:52 derick Assigned To => derick
2015-07-02 08:52 derick Status new => feedback
2015-07-11 01:24 tien.xuan.vo Note Added: 0003149
2015-07-11 01:24 tien.xuan.vo Status feedback => assigned
2015-07-11 01:25 tien.xuan.vo File Added: xdebug.log
2016-07-31 12:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 12:35 derick Category debugclient (debugging tool) => (No Category)
2016-12-12 00:13 derick PHP Version 5.6-dev => 5.1.0
2016-12-12 00:13 derick Category (No Category) => Remote Debugging
2016-12-12 00:14 derick Note Added: 0004028
2016-12-12 00:14 derick Status assigned => feedback
2017-01-03 18:55 derick Note Added: 0004139
2017-01-03 18:55 derick Status feedback => resolved
2017-01-03 18:55 derick Resolution open => unable to reproduce