View Issue Details

IDProjectCategoryView StatusLast Update
0001198XdebugUsage problems (Wrong Results)public2015-11-20 17:46
ReporterrastaAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionunable to reproduce 
PlatformMacOSOS XOS Version10.11.1
Product Version2.4.0beta1 
Target VersionFixed in Version 
Summary0001198: Using PHPStorm with PHP 7 RC1 and xdebug 2.4.0beta1 break points are passed by including setting break point at start of script
DescriptionI'm using PHPSTORM 10 and Homebrew PHP 7.0RC6

Compiled the latest release of xdebug and was able to get PHPStorm 10 with PHP 7 RC6 as the interepeter to recognize the xdebug.so module and load it without errors. Ran a Symfony 2 app in debug mode (from web and from console), but all break points are ignored. Configured to always break on start and that too is ignored.

Switched PHPStorm 10 works great with php 5.6 and xdebug btw.
Steps To ReproduceUse any tested application.

Build PHP 7.0.0RC6 if you haven't already.

brew install php70 --with-homebrew-curl --with-homebrew-libxslt --with-postgresql

Build xdebug 2.4.0beta1, set the php.ini file etc.

brew install php70-xdebug

xdebug.ini:

[xdebug]
zend_extension="/usr/local/opt/php70-xdebug/xdebug.so"

debug.remote_enable=on
xdebug.remote_handler=dbgp
xdebug.remote_host=localhost
xdebug.remote_port=9090 - port is ok, this works in my 5.6 setup
xdebug.cli_color=1
xdebug.remote_autostart=1
xdebug.idekey="PHPSTORM"

xdebug.max_nesting_level = 1000

Configure PHPStorm to use PHP 7.0.0RC1 as the interpreter and make sure xdebug is configured as the debugger.
Set a break point in the index.php file. (app_dev.php in symfony)

Configure a run debugger to start with test.php and run test.php in debug mode.
Observe that all break points are ignored.
Even setting PHPStorm to break at start of the script does not work.
Additional Informationphp -v

PHP 7.0.0RC6 (cli) (built: Nov 7 2015 00:37:15) ( NTS )
Copyright (c) 1997-2015 The PHP Group
Zend Engine v3.0.0-dev, Copyright (c) 1998-2015 Zend Technologies
    with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2015, by Zend Technologies
    with Xdebug v2.4.0beta1, Copyright (c) 2002-2015, by Derick Rethans
TagsNo tags attached.
Operating System
PHP Version7.0.0rc6

Activities

rasta

2015-11-09 19:09

reporter   ~0003221

Somehow by mistake this task is tagged as a PHP 5.6 Issue, it should be changed to PHP 7

derick

2015-11-18 22:34

administrator   ~0003234

Just updating the PHP version.

derick

2015-11-20 17:46

administrator   ~0003238

This is unlikely to be a bug. Please contact PHP Storm support to figure out why it doesn't work, as locally, it works just perfectly.

Issue History

Date Modified Username Field Change
2015-11-07 22:13 rasta New Issue
2015-11-09 19:09 rasta Note Added: 0003221
2015-11-18 22:34 derick PHP Version 5.6.10-5.6.14 => 7.0.0rc6
2015-11-18 22:34 derick Note Added: 0003234
2015-11-20 17:46 derick Note Added: 0003238
2015-11-20 17:46 derick Status new => resolved
2015-11-20 17:46 derick Resolution open => unable to reproduce
2015-11-20 17:46 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)