View Issue Details

IDProjectCategoryView StatusLast Update
0000123XdebugUsage problems (Wrong Results)public2005-04-08 08:39
Reporter0x33Assigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0000123: Segmentation fault with __autoload
DescriptionWhen using PHP5's __autoload function, apache segfault if xdebug is enabled. (See code below to reproduce the error)

PHP : 5.0.[3-4]
xdebug : 1.3.2
Additional InformationFile a.php

<?php
class a {
    public function request($key, $default = '') {
        return (isset($_REQUEST[$key])) ? $_REQUEST[$key] : $default;
    }
}
?>

File b.php

<?php
class b {
    const CONST_NAME = 'OK';
}
?>

File main.php

<?php
function __autoload($class_name) {
    include_once $class_name . '.php';
}
class Foo {
    public function bar() {
        echo a::request('var', b::CONST_NAME);
    }
}
$foo = new Foo;
$foo->bar();
?>
TagsNo tags attached.
Operating SystemDebian Woody (stable) with PHP5 dotdeb package
PHP Version5.0.2

Relationships

duplicate of 0000078 closed segfault with set_exception_handler() 

Activities

derick

2005-04-08 08:39

administrator   ~0000253

Duplicate of 0000078 - which is fixed in CVS already.

Issue History

Date Modified Username Field Change
2005-04-07 22:52 0x33 New Issue
2005-04-08 08:39 derick Status new => resolved
2005-04-08 08:39 derick Resolution open => duplicate
2005-04-08 08:39 derick Relationship added duplicate of 0000078
2005-04-08 08:39 derick Assigned To => derick
2005-04-08 08:39 derick Note Added: 0000253
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)