View Issue Details

IDProjectCategoryView StatusLast Update
0001244XdebugUsage problems (Wrong Results)public2016-12-04 15:14
ReporterjoefallonAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformLinuxOSUbuntuOS Version14.04 LTS
Product Version2.4.0rc3 
Target VersionFixed in Version 
Summary0001244: SIGSEGV When Using xdebug_start_code_coverage
Descriptionxdebug_start_code_coverage(XDEBUG_CC_UNUSED | XDEBUG_CC_DEAD_CODE) crashes PHP7 with a SIGSEGV.

When using xdebug_start_code_coverage(XDEBUG_CC_UNUSED) everything works fine.
Steps To ReproduceSee above.
Additional InformationN/A
TagsNo tags attached.
Operating SystemUbuntu 14.04 LTS
PHP Version7.0.0-7.0.4

Activities

zaq178miami

2016-01-11 02:09

reporter   ~0003393

Last edited: 2016-01-11 02:18

View 2 revisions

Not sure whether I experience the same bug or not, but here is bt in travis build: https://travis-ci.org/pinepain/php-weak-lib/builds/101496046#L443

Happened when I try to run tests against PHP nightly build with my php-weak extension.

With php 7.0.0 build is green with and without codecoverage https://travis-ci.org/pinepain/php-weak-lib/builds/101491413.

Worth to mention that my ext backup obj handlers and then replace it with modified handler struct where dtor_obj wrapped with custom ext function.

Here is valgrind report - https://gist.github.com/pinepain/aae4eff78695b8808a48

derick

2016-01-11 22:15

administrator   ~0003396

Could you please try Xdebug from github's master branch? I fixed a few things. If that doesn't fix it, I will need to have short script that reproduces the issue please. To go with that, a nice backtrace (hints on how to make them: https://bugs.php.net/bugs-generating-backtrace.php) would be great too.

zaq178miami

2016-01-11 23:13

reporter   ~0003401

I tried on my local machine, php is from master and xdebug too. Same result. After digging yesterday around a bit and disabling all extension it looks like my report should goes to http://bugs.xdebug.org/view.php?id=1246. Will provide report there.

derick

2016-12-04 15:14

administrator   ~0003898

I am closing this, as joefallon never replied with additional information, and http://bugs.xdebug.org/view.php?id=1246 is confirmed fixed by zaq178miami.

Issue History

Date Modified Username Field Change
2016-01-08 21:53 joefallon New Issue
2016-01-11 02:09 zaq178miami Note Added: 0003393
2016-01-11 02:18 zaq178miami Note Edited: 0003393 View Revisions
2016-01-11 22:15 derick Note Added: 0003396
2016-01-11 22:15 derick Assigned To => derick
2016-01-11 22:15 derick Status new => feedback
2016-01-11 23:13 zaq178miami Note Added: 0003401
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)
2016-12-04 15:14 derick Note Added: 0003898
2016-12-04 15:14 derick Status feedback => resolved
2016-12-04 15:14 derick Resolution open => unable to reproduce