View Issue Details

IDProjectCategoryView StatusLast Update
0001247XdebugUsage problems (Wrong Results)public2016-02-08 17:34
ReporterPitmanAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformLinuxOSXubuntuOS Version15.10
Product Version2.4.0rc3 
Target VersionFixed in Version 
Summary0001247: xdebug.show_local_vars dumps variables with *uninitialized* values
DescriptionAlso, in manual: "dumps in error situations will also show all variables in the top-most scope"

But, it dumps only variables in function/method scopes (with *uninitialized* values)
TagsNo tags attached.
Operating System
PHP Version7.0.0-7.0.4

Activities

derick

2016-01-11 21:36

administrator   ~0003394

I am not sure whether I understand this issue. Could you provide a short (up to 20 lines) script that illustrates the problem - and which php.ini settings you have made for xdebug.* settings?

Pitman

2016-02-05 21:14

reporter   ~0003440

Can't reproduce any more, please close the ticket.

derick

2016-02-08 17:34

administrator   ~0003444

Okay - I'm closing it. Please feel free to reopen when you encounter it again.

Issue History

Date Modified Username Field Change
2016-01-11 17:42 Pitman New Issue
2016-01-11 21:36 derick Note Added: 0003394
2016-01-11 21:36 derick Assigned To => derick
2016-01-11 21:36 derick Status new => feedback
2016-02-05 21:14 Pitman Note Added: 0003440
2016-02-05 21:14 Pitman Status feedback => assigned
2016-02-08 17:34 derick Note Added: 0003444
2016-02-08 17:34 derick Status assigned => resolved
2016-02-08 17:34 derick Resolution open => unable to reproduce
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)