View Issue Details

IDProjectCategoryView StatusLast Update
0001249Xdebug(No Category)public2016-02-27 15:58
ReporterakinocalAssigned Toderick 
PriorityhighSeveritycrashReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformWindowsOS Server 2012OS VersionR2
Product Version2.4.0rc3 
Target VersionFixed in Version 
Summary0001249: Crash when using with Jetbrains Phpstorm 10
Description$myArray = array
(
    array("name" => "something", "value1" => $accept_language, "type" => PEAR_VARCHAR),
    array("name" => "something2", "value2" => $user_agent, "type" => PEAR_VARCHAR)
);

After passing the line above , in phpstorm10, we try to view the members of myArray , and we get a crash right at that point.
Steps To Reproduce1. In phpstorm , create a dummy project and just declare an array as showns in the description part

2. In debugging session , place a breakponit after the declaration line then hover the mouse over that array variable and then press Ctrl+F1 or try to click on members of that array by clicking on
Additional InformationWas able to repro with RC1 as well

Callstack :

00 04fae44c 624dc39f php7!libiconv_set_relocation_prefix+0x2d9
*** ERROR: Symbol file could not be found. Defaulted to export symbols for C:\Windows\SYSTEM32\ucrtbase.DLL -
01 04fae468 6a07c0f8 php_xdebug!xdebug_init_oparray+0x1642f
02 04fae484 624d8de2 ucrtbase!atoldbl_l+0x2a8
03 04fae4c8 624cd5e3 php_xdebug!xdebug_init_oparray+0x12e72
04 04fae4f4 624d1903 php_xdebug!xdebug_init_oparray+0x7673
05 04fae520 624d1a28 php_xdebug!xdebug_init_oparray+0xb993
06 04fae548 624ca7a6 php_xdebug!xdebug_init_oparray+0xbab8
07 00000000 00000000 php_xdebug!xdebug_init_oparray+0x4836
TagsNo tags attached.
Operating System
PHP Version7.0.0-7.0.4

Activities

derick

2016-02-08 21:06

administrator   ~0003453

Can you please follow the instructions at https://xdebug.org/support.php#remote to provide me with the required information please?

derick

2016-02-27 15:58

administrator   ~0003521

Closing this out, as I can't reproduce this and not reproducible case was submitted.

Issue History

Date Modified Username Field Change
2016-01-12 17:36 akinocal New Issue
2016-02-08 21:06 derick Note Added: 0003453
2016-02-08 21:06 derick Assigned To => derick
2016-02-08 21:06 derick Status new => feedback
2016-02-27 15:58 derick Note Added: 0003521
2016-02-27 15:58 derick Status feedback => resolved
2016-02-27 15:58 derick Resolution open => unable to reproduce
2016-07-31 12:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 12:35 derick Category debugclient (debugging tool) => (No Category)