View Issue Details

IDProjectCategoryView StatusLast Update
0001251XdebugUsage problems (Wrong Results)public2016-02-09 10:56
ReporterDevDonkeyAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version2.4.0rc3 
Target VersionFixed in Version 
Summary0001251: Segmentation fault occurring on system shutdown. Causing big delay in apache shutting down.
Descriptionon going through logs after a continuing problem in shutting down I noticed the attached log entry that I thought you should be aware of.
Steps To Reproduceapache2 running at shutdown
Additional Information2.4rc3, any version of PHP
TagsNo tags attached.
Operating SystemUbuntu 15.10 x64
PHP Version7.0.0-7.0.4

Activities

DevDonkey

2016-01-13 10:46

reporter  

apache.crash (4,686 bytes)

derick

2016-01-13 11:05

administrator   ~0003419

Has this happened once, or multiple times? It looks like a debugging session was still active when you shut-down apache, but without Apache's symbol tables it's hard to say. Could you install the apache-dbg package, and "hope" this happens again?

derick

2016-02-08 21:07

administrator   ~0003454

Can you please answer the questions from the previous note?

DevDonkey

2016-02-09 10:53

reporter   ~0003467

sorry derick, I totally forgot about this one.

The issue actually turned out to be redis crashing on shutdown. Oddly this was logged inaccurately by apache that led me up the wrong path.

derick

2016-02-09 10:56

administrator   ~0003468

That's okay - closing this one out then.

Issue History

Date Modified Username Field Change
2016-01-13 10:46 DevDonkey New Issue
2016-01-13 10:46 DevDonkey File Added: apache.crash
2016-01-13 11:05 derick Note Added: 0003419
2016-01-13 11:05 derick Assigned To => derick
2016-01-13 11:05 derick Status new => feedback
2016-02-08 21:07 derick Note Added: 0003454
2016-02-09 10:53 DevDonkey Note Added: 0003467
2016-02-09 10:53 DevDonkey Status feedback => assigned
2016-02-09 10:56 derick Note Added: 0003468
2016-02-09 10:56 derick Status assigned => resolved
2016-02-09 10:56 derick Resolution open => no change required
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)