View Issue Details

IDProjectCategoryView StatusLast Update
0001271XdebugUsage problems (Wrong Results)public2016-12-04 15:20
ReporterwychurrAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionunable to reproduce 
Platformphp build in serverOSwindowsOS Version10
Product Version2.4.0rc4 
Target VersionFixed in Version 
Summary0001271: PHP code “return xxx” may case crash
Descriptionwhile I am using xdebug and laravel framework, if include the Zizaco\Entrust package,
the php-cli will crash in "return" expression
but it not happen in all computer
I tried to debug into php7.dll ,but I dont hav php_xdebug.dll debug version
could you send me the debug version by email ;)
-------------------------------------------------
VS2015 catch the win32 exception:
Unhandled exception at 0x00007FF9EAD87EA0 (ucrtbase.dll) (php.exe ): 0xC0000005: Access violation reading location 0xFFFFFFFFFFFFFFFF

---------------------
stack trace ?
> ucrtbase.dll!00007ff9ead87ea0()
     php_xdebug-2.4.0rc4-7.0-vc14-nts-x86_64.dll!00007ff9d14d6154()
     php_xdebug-2.4.0rc4-7.0-vc14-nts-x86_64.dll!00007ff9d14c4a15()
     php7.dll!00007ff9c1dba27a()
     php7.dll!00007ff9c1e71ce1()
     php7.dll!00007ff9c1a6ad42()
     php_xdebug-2.4.0rc4-7.0-vc14-nts-x86_64.dll!00007ff9d14c49e7()
     php7.dll!00007ff9c1e2c0b1()
     php7.dll!00007ff9c1a6ad42()
     php_xdebug-2.4.0rc4-7.0-vc14-nts-x86_64.dll!00007ff9d14c49e7()
     php7.dll!00007ff9c1dba27a()
     php7.dll!00007ff9c1e71ce1()
     php7.dll!00007ff9c1a6ad42()
     php_xdebug-2.4.0rc4-7.0-vc14-nts-x86_64.dll!00007ff9d14c49e7()
     php7.dll!00007ff9c1dba27a()
     php7.dll!00007ff9c1e71ce1()
     php7.dll!00007ff9c1a6ad42()
     php_xdebug-2.4.0rc4-7.0-vc14-nts-x86_64.dll!00007ff9d14c49e7()
     php7.dll!00007ff9c1dba27a()
     php7.dll!00007ff9c1e71ce1()
     php7.dll!00007ff9c1a6ad42()
     php_xdebug-2.4.0rc4-7.0-vc14-nts-x86_64.dll!00007ff9d14c49e7()
     php7.dll!00007ff9c1dba27a()
     php7.dll!00007ff9c1e71ce1()
     php7.dll!00007ff9c1a6ad42()
     php_xdebug-2.4.0rc4-7.0-vc14-nts-x86_64.dll!00007ff9d14c49e7()
     php7.dll!00007ff9c1dba27a()
     php7.dll!00007ff9c1e71ce1()
     php7.dll!00007ff9c1a6ad42()
     php_xdebug-2.4.0rc4-7.0-vc14-nts-x86_64.dll!00007ff9d14c49e7()
     php7.dll!00007ff9c1db99ed()
     php7.dll!00007ff9c1bb7082()
     php_xdebug-2.4.0rc4-7.0-vc14-nts-x86_64.dll!00007ff9d14c4d96()
     php7.dll!00007ff9c1a6452b()
     php7.dll!00007ff9c1e71ce1()
     php7.dll!00007ff9c1a6ad42()
     php_xdebug-2.4.0rc4-7.0-vc14-nts-x86_64.dll!00007ff9d14c49e7()
     php7.dll!00007ff9c1dba27a()
     php7.dll!00007ff9c1e71ce1()
     php7.dll!00007ff9c1a6ad42()
     php_xdebug-2.4.0rc4-7.0-vc14-nts-x86_64.dll!00007ff9d14c49e7()
     php7.dll!00007ff9c1dba27a()
     php7.dll!00007ff9c1e71ce1()
     php7.dll!00007ff9c1a6ad42()
     php_xdebug-2.4.0rc4-7.0-vc14-nts-x86_64.dll!00007ff9d14c49e7()
     php7.dll!00007ff9c1dba27a()
     php7.dll!00007ff9c1e71ce1()
     php7.dll!00007ff9c1a6ad42()
     php_xdebug-2.4.0rc4-7.0-vc14-nts-x86_64.dll!00007ff9d14c49e7()
     php7.dll!00007ff9c1dba27a()
     php7.dll!00007ff9c1e71ce1()
     php7.dll!00007ff9c1a6ad42()
     php_xdebug-2.4.0rc4-7.0-vc14-nts-x86_64.dll!00007ff9d14c49e7()
     php7.dll!00007ff9c1dba27a()
     php7.dll!00007ff9c1e71ce1()
     php7.dll!00007ff9c1a6ad42()
     php_xdebug-2.4.0rc4-7.0-vc14-nts-x86_64.dll!00007ff9d14c49e7()
     php7.dll!00007ff9c1dba27a()
     php7.dll!00007ff9c1e71ce1()
     php7.dll!00007ff9c1a6ad42()
     php_xdebug-2.4.0rc4-7.0-vc14-nts-x86_64.dll!00007ff9d14c49e7()
     php7.dll!00007ff9c1dba27a()
     php7.dll!00007ff9c1e71ce1()
     php7.dll!00007ff9c1a6ad42()
     php_xdebug-2.4.0rc4-7.0-vc14-nts-x86_64.dll!00007ff9d14c49e7()
     php7.dll!00007ff9c1dba27a()
     php7.dll!00007ff9c1e71ce1()
     php7.dll!00007ff9c1a6ad42()
     php_xdebug-2.4.0rc4-7.0-vc14-nts-x86_64.dll!00007ff9d14c49e7()
     php7.dll!00007ff9c1dba27a()
     php7.dll!00007ff9c1e71ce1()
     php7.dll!00007ff9c1a6ad42()
     php_xdebug-2.4.0rc4-7.0-vc14-nts-x86_64.dll!00007ff9d14c49e7()
     php7.dll!00007ff9c1dba27a()
     php7.dll!00007ff9c1e71ce1()
     php7.dll!00007ff9c1a6ad42()
     php_xdebug-2.4.0rc4-7.0-vc14-nts-x86_64.dll!00007ff9d14c49e7()
     php7.dll!00007ff9c1a8d38c()
     php7.dll!00007ff9c1a8d179()
     php7.dll!00007ff9c1a8cfe3()
     php.exe!00007ff78f3a6bf4()
     php.exe!00007ff78f3a6908()
     php.exe!00007ff78f3a7558()
     php.exe!00007ff78f3a6dac()
     php.exe!00007ff78f3a73cb()
     php.exe!00007ff78f3a6e8c()
     php.exe!00007ff78f3a53ad()
     php.exe!00007ff78f3a32ed()
     php.exe!00007ff78f3a25e0()
TagsNo tags attached.
Operating Systemwindows 10
PHP Version7.0.0-7.0.4

Activities

wychurr

2016-02-16 09:57

reporter   ~0003496

windows 10 x64
-----------------------
$ php -v
PHP 7.0.2 (cli) (built: Jan 6 2016 12:59:59) ( NTS )
Copyright (c) 1997-2015 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2015 Zend Technologies
    with Xdebug v2.4.0RC4, Copyright (c) 2002-2016, by Derick Rethans
----------------------
> ucrtbase.dll!00007ff9ead87ea0()

00007FF9EAD87EA0 cmp byte ptr [rcx+rbx],0

        RBX 0000000000000000
        RCX 6E6564692420207C

derick

2016-02-23 22:49

administrator   ~0003519

I'm going to need a short reproducible case. I can't guess from "I use this module" and a stack trace.

derick

2016-02-27 16:01

administrator   ~0003529

Ping?

derick

2016-12-04 15:20

administrator   ~0003902

I can not reproduce this, and the requested feedback was not supplied. Please reopen this issue if you can still reproduce this with the requested short script.

Issue History

Date Modified Username Field Change
2016-02-16 09:45 wychurr New Issue
2016-02-16 09:57 wychurr Note Added: 0003496
2016-02-23 22:49 derick Note Added: 0003519
2016-02-23 22:49 derick Assigned To => derick
2016-02-23 22:49 derick Status new => feedback
2016-02-27 16:01 derick Note Added: 0003529
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)
2016-12-04 15:20 derick Note Added: 0003902
2016-12-04 15:20 derick Status feedback => resolved
2016-12-04 15:20 derick Resolution open => unable to reproduce