View Issue Details

IDProjectCategoryView StatusLast Update
0001308XdebugStep Debuggingpublic2017-01-03 18:48
Reporternikolay Assigned Toderick  
PriorityhighSeveritycrashReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformEclipse PDT 2.0OSMAC OS X 10.11.5 El CapitanOS Version10.11.5
Product Version2.4.0 
Summary0001308: Debugging php file crashed due to unexpected error (arrays involved)
DescriptionFirstly, I apologise if such topic has already been discussed.
I use MAC OS X 10.11.5 El Capitan.
I use Eclipse PDT.
I use php v. 7.0.6.
I use xDebug 2.4.0.
When I try to debug this script. I receive an error "unexpected termination of script, debugging ended". It is only when I debug scripts that have arrays in them and I want to change/add their values.
The script I uploaded is just a simple example.
TagsNo tags attached.
Operating SystemMAC OS X 10.11.5
PHP Version7.0.5-7.0.9

Activities

nikolay

2016-06-03 23:24

reporter  

test03.php (198 bytes)   
<?php

require_once 'readline.php';

$number = readline('Enter a number: ');
$array = [$number, $number];
for ($i = 2; $i < 10; $i++) {
	$array [] = $array[$i-2] + $array[$i-1];
}

print_r ($array);
test03.php (198 bytes)   

nikolay

2016-06-04 10:05

reporter   ~0003623

Additional information: I set $array in the expressions watch window and I debug the program step by step.

derick

2016-06-05 19:41

administrator   ~0003626

Please follow the instructions at https://xdebug.org/support.php#remote to help me find debugging bugs.

derick

2016-12-04 19:13

administrator   ~0003932

Ping?

derick

2017-01-03 18:48

administrator   ~0004126

I could not reproduce this, and no additional information was presented. I am therefore closing this report.

Issue History

Date Modified Username Field Change
2016-06-03 23:24 nikolay New Issue
2016-06-03 23:24 nikolay File Added: test03.php
2016-06-04 10:05 nikolay Note Added: 0003623
2016-06-05 19:41 derick Note Added: 0003626
2016-06-05 19:41 derick Assigned To => derick
2016-06-05 19:41 derick Status new => feedback
2016-07-31 12:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 12:35 derick Category debugclient (debugging tool) => (No Category)
2016-12-04 19:13 derick Note Added: 0003932
2016-12-04 19:13 derick Category (No Category) => Remote Debugging
2017-01-03 18:48 derick Note Added: 0004126
2017-01-03 18:48 derick Status feedback => resolved
2017-01-03 18:48 derick Resolution open => unable to reproduce
2020-03-12 16:33 derick Category Remote Debugging => Step Debugging